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GIS Support Tutorial: Introduction

v

The National Oceanic and Atmospheric Administration’s (NOAA) Coastal Services Center developed this GIS Support 
Tutorial for members of the Federal Emergency Management Agency (FEMA) and their contractors. The tutorial 
provides guidance to those using ArcGIS for map production before, during, and after hurricanes.

Though this tutorial focuses on novice users of geographic information systems, or GIS, those users who have not taken 
the Environmental Systems Research Institute’s (ESRI) Introduction to ArcGIS I course (or similar introductory ArcGIS 
training) should first familiarize themselves with basic GIS concepts and cartographic principles.

This tutorial provides guidance in the following ways:

• Discussion of where to find NOAA National Weather Service data and other related resources

• Basic direction on how to use ArcGIS for cartographic production

• Standard cartographic principles in designing specific presentation-quality maps for FEMA’s use
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GIS Support Tutorial: Mapping Timeline

vi

A general timeline is provided to show when each product may be created, but timing of products can be altered based 
on specific characteristics of an event.

Landfall
Post-    

Landfall
Day  -3 Day  -2 Day  -1 Day 0 Day 1

1 6-Hour Quantitative Precipitation Forecast
2 Forecast Waveheight
3 Forecast Windspeed
4 120-Hour Quantitative Precipitation Forecast
5 NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
6 24-Hour Stage III Rainfall
7 Cumulative Rainfall - Stage III Multi-Sensor Precipitation Estimate
8 SLOSH Model Run - hypothetical (h), or real-time (r) h h r r
9 6 Hour Flash Flood Guidance
10 120-Hour QPF / 6-Hour Flash Flood Guidance Difference
11 Stage III Rainfall / 6-Hour Flash Flood Guidance Difference
12 Significant River Flood Outlook
13 Tropical Cyclone Wind Speed Probabilities

Pre-                      
Landfall

Chapter/Product
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GIS Support Tutorial: Requirements

vii

To complete this tutorial, you will need the following tools:

ArcGIS, ArcView version 8.x or higher with the Spatial Analyst extension
Contact Information

Environmental Systems Research Institute (ESRI)
www.esri.com

HURREVAC
Contact Information

John F. Townsend 
Sea Island Software Inc. 
(843) 881-0593 
www.hurrevac.com 
support@hurrevac.com

SLOSH Display Program – with GIS shapefile export capability enabled
Contact Information

Arthur Taylor Wilson (Wil) Shaffer
Arthur.Taylor@noaa.gov Wilson.Shaffer@noaa.gov
(301) 713-1613, x163 (301) 713-1613, x167 

Continued on next page…
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GIS Support Tutorial: Requirements

viii

National Digital Forecast Database (NDFD) GRIB2 Decoder
Contact Information

Arthur Taylor
Arthur.Taylor@noaa.gov
(301) 713-1613, x163
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php

A file decompression utility such as WinZip or PKZIP – This software allows you to extract compressed 
shapefiles that are used throughout the tutorial.

WinZip – www.winzip.com/downwzeval.htm
PKZIP – http://nct.digitalriver.com/fulfill/0018.18

Adobe PDF – Finished maps are exported to .pdf format for easy exchange and printing. This software allows 
you to create these files.

www.adobe.com/products/acrobatpro/tryout.html

Other Resources
NOAA Coastal Services Center Storm Info Web site – This site provides links to many of the data sources 

listed in the tutorial.
www.csc.noaa.gov/storm_info/guide.html

FEMA’s floodmaps.net – This site is for use by those actively engaged in flood hazard mapping, maintenance, 
and update. This site’s Easy FTP page allows you to share large files with others.

www.floodmaps.net/eftp/
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6-Hour Quantitative Precipitation Forecast

Purpose: This type of map presents a 6-hour estimate of the amount of expected rainfall for a given area. The 
information is displayed as a summary of total predicted rainfall, measured in inches, for that period of time.

Source Data: This type of map uses the NOAA National Weather Service’s National Digital Forecast Database 
(NDFD), found at www.nws.noaa.gov/ndfd/. The National Weather Service (NWS) provides access to gridded 
forecasts of weather elements (e.g., cloud cover, maximum temperature) through the NDFD. This database contains a 
seamless mosaic of digital forecasts from NWS field offices working with the National Centers for Environmental 
Prediction (NCEP). The database uses a 5-kilometer national grid that covers the continental U.S. and separate grids 
that cover Hawaii, Alaska, the U.S. Virgin Islands, and Puerto Rico. Each 5-kilometer grid cell has forecast 
information, allowing users to retrieve specific forecasts by entering geographic coordinates. 

The World Meteorological Organization (WMO) has adopted Edition 2 of the gridded binary data (GRIB) code as a 
standard for sharing information. GRIB, Edition 2 (GRIB2), is involved in the NDFD in two ways. First, GRIB2 is the 
code form used to transmit gridded forecasts from contributing offices to the NDFD. Second, GRIB2 is one of the 
primary forms used to transmit the NDFD grids to NWS customers and partners. Users should note that this should be 
considered an experimental product at the time of this writing (March 2006).

Download: Before working with NDFD data, users must first download the GRIB2 Decoder tool that allows access to 
the data. Learn more about GRIB2 Decoder by visiting this site: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/
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6-Hour Quantitative Precipitation Forecast

Download: Register for the DEGRIB program here: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php
At the top of the page, under step 1, click on the highlighted link to register and download the program.

Double-click on degrib-install.exe to install the program.  
A window will appear; click on the Install button and 
accept the defaults for the installer.

Once done, download the program from here:  
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/download.php

This page provides several different versions of the same product.  
For this tutorial, you will focus on the Microsoft Windows version.  
Click on degrib-install.exe and select Save. Specify the directory 
path for the program as c:/ndfd and copy the .exe into that folder.  
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6-Hour Quantitative Precipitation Forecast

Then click on the Download tab and expand the 
NDFD data set folder if it is not already open.

Choose the region of interest and expand the file.  
Choose the days of interest and expand the folder. 

Data for each weather element can be downloaded by 
highlighting the entire region folder, or individual 
weather elements can be downloaded by holding down 
the Control key on the keyboard and highlighting one 
or more elements. 

Click on QPF (quantitative precipitation forecast), and 
then click on either the Download by FTP or the 
Download by HTTP button (either will work) at the 
bottom of the window. 

Once downloading begins, there will be an indication in 
the Message Window that it is working. Also, after the 
download button is clicked, the light blue bar near the 
bottom of the window will show the progress of the 
data download. 

Download: Double-click on tkdegrib (aka NDFD GRIB2 Decoder) to start the program.
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6-Hour Quantitative Precipitation Forecast

This file contains important data in a binary format. Unfortunately, 
ArcGIS is unable to read this format, so the data must be 
converted into a shapefile.

Close Windows Explorer and return to the tkdegrib (aka NDFD 
GRIB2 Decoder) program.

View the data: Minimize this program and open Windows Explorer. Navigate to C:\ndfd\degrib18\data\ndfd\smissvly and 
notice that qpf.bin is stored in that directory.
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6-Hour Quantitative Precipitation Forecast

Select the first in the list, which provides the 6-hour 
forecast. 

An easy way to create an output shapefile inside the 
Output Filename window is to simply click on the 
Recommend button. Ideally, you should keep all of 
your regional files in the same directory (i.e., 
smissvly).

Specify the File Type as SHP (shapefile).

Specify the type of shapefile to be Large Polygon. 

Specify Round data to: 1 decimal.

When finished, click the Generate .shp file button. 
This will create a new shapefile and copy it into your 
specified folder. Notice that it is in a different folder 
than the qpf.bin file.

Convert the data: Click on the GIS tab. This window lets users choose a file to convert to various GIS-friendly formats.  
Navigate to the directory of your .bin file. Double-click on qpf.bin to see a series of precipitation forecasts.

When finished, click on the window that reads Done. Minimize the program and open ArcMap.
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Add data by clicking on the Add Data button              
found at the top of the ArcMap window. This will start a 
dialog window that lets users browse to their data.

6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: ArcMap can be started by selecting Start > Programs > ArcGIS > ArcMap

Select the file and click Add. Notice the layer is now   
added to the top of the table of contents in ArcMap.

The data should now be symbolized to show the amounts 
of precipitation expected in the area.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Double-click on the shapefile layer in ArcMap’s table of contents. This opens the Layer 
Properties dialog box.  

Click on the Symbology tab to specify a predefined legend.

Click on the Import button to browse to predefined layer files.  



Map Production 1-8

For FEMA
GIS Support Tutorial

6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: In the Import Symbology 
dialog box, choose to Import symbology definition from an 
ArcView 3 legend file (*.avl).  

Click on the Browse button              and navigate to 
C:\ndfd\degrib17\arcview\poly_legend. 

Select qpf.avl and click on the Open button.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: In the Import Symbology Matching Dialog 
window, take the default QPF values listed in the Value Field drop-down menu.  

Click OK.

Notice that a predefined set of symbols and values has 
been added under the Symbology tab. Click OK to assign 
these to the data.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: The resulting symbology color ramp will be assigned to the polygons of the QPF layer 
according to their predicted precipitation amounts for the next 6 hours.

Of course, you cannot tell where this area is 
located. To do so, add a layer of county boundaries.

A good resource for ancillary base map data is the 
NOAA Advanced Weather Information Processing 
System (AWIPS) Web site:
www.nws.noaa.gov/geodata/

Open a Web browser and navigate to this site.  
Scroll down the Web page and look for a section 
called County Libraries.

Click on the AWIPS Counties link. This is the most 
recent county boundary information.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Click on the Download Compressed Shapefile link. This allows you to permanently 
save the file onto your system. Click on the Save button when prompted, and specify a new folder (i.e., c:\AWIPS_Data).
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Using Windows Explorer, navigate to this new folder once the compressed .zip file is 
saved. Double-click on the file to use a zip utility to uncompress it.

Save the uncompressed shapefile into the AWIPS_Data folder.



Map Production 1-13

For FEMA
GIS Support Tutorial

6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Once uncompressed, add the 
county boundary layer to ArcMap. You may receive a warning 
message alerting you that the county boundary layer does not 
contain spatial reference (projection properties). However, ArcMap
is able to properly reconcile this layer with the QPF layer. 
Simply click OK to dismiss this window.

By default, the county boundary layer will be added at the 
top of the table of contents. As a result, it will obscure the 
QPF data. Rearrange the layers so you can see which 
counties will receive rain in the next 6 hours. 

Collapse the classes of the QPF layer by clicking on the 
minus sign next to the name of the layer.  Next, click and 
drag the county boundary layer below the QPF layer.

Note: The Display tab at the bottom of the table of contents 
must be selected before you can reorder the layers.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Unfortunately, the QPF layer has the color “white” assigned to polygons that will not 
receive precipitation (0.0 inches). This needs to be changed so other layers will be visible. 

Double-click on the QPF layer to open its Layer Properties 
window.  

Click on the Symbology tab to reveal the color ramp. 
Double-click on the “white” class that is assigned to the “0” 
value. This will open the Symbol Selector window.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Click on the Fill Color button and specify No Color so a transparency can be set for 
these QPF polygons. Do the same for the Outline Color button so the polygons will not be outlined. Click OK to make 
the change.

Use the Zoom In tool for a closer look at the area around this 
rain event.  

Click OK in the Layer Properties window. The newly 
symbolized layer will display.
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Because the QPF data are a solid fill, you cannot see the counties that are going to be 
affected. Set a transparency for this layer by opening the Layer Properties window (remember how?).                             

Click on the Display tab and change the transparency 
amount from 0% to 40%.  Click OK to make the change. 
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6-Hour Quantitative Precipitation Forecast

Add and symbolize the data: Retain the colors and class assignments of the symbology for future mapping. This is 
done by making a “layer file” of the layer. Right-click on the QPF layer and select Save As Layer File.  

Click Save once you are done.

At this point, you are ready to begin making a map. Several examples have been included to give some guidance on what 
the NOAA Coastal Services Center has provided to members of FEMA in the past. Refer to the “Basics of Cartography” 
chapter at the end of this manual for additional information.

The following dialog window allows you to navigate to a 
folder and specify a name for the new layer file. You should 
always create this inside the same folder as the layer itself.  
Notice the .lyr extension that is added to the file.
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6-Hour Quantitative Precipitation Forecast
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Purpose: This type of map presents an estimate of the significant wave height, measured in feet, for a given area. 
Significant wave height is approximately equal to the highest one-third of waves passing a certain point.

Source Data: This type of map uses the NOAA National Weather Service’s National Digital Forecast Database (NDFD), 
found at www.nws.noaa.gov/ndfd/. The National Weather Service (NWS) provides access to gridded forecasts of 
weather elements (e.g., cloud cover, maximum temperature) through the NDFD. This database contains a seamless 
mosaic of digital forecasts from NWS field offices working with the National Centers for Environmental Prediction 
(NCEP). The database uses a 5-kilometer national grid that covers the continental U.S. and separate grids that cover 
Hawaii, Alaska, the U.S. Virgin Islands, and Puerto Rico. Each 5-kilometer grid cell has forecast information, allowing 
users to retrieve specific forecasts by entering geographic coordinates. 

The World Meteorological Organization (WMO) has adopted Edition 2 of the gridded binary data (GRIB) code as a 
standard for sharing information. GRIB, Edition 2 (GRIB2), is involved in the NDFD in two ways. First, GRIB2 is the code 
form used to transmit gridded forecasts from contributing offices to the NDFD. Second, GRIB2 is one of the primary 
forms used to transmit the NDFD grids to NWS customers and partners. Users should note that this should be 
considered an experimental product at the time of this writing (March 2006).

Download: Before working with NDFD data, users must first download the GRIB2 Decoder tool that allows access to the 
data. Learn more about GRIB2 Decoder by visiting this site: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/

Forecast Waveheight
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Forecast Waveheight

Download: Register for the DEGRIB program here: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php
At the top of the page, under step 1, click on the highlighted link to register and download the program.

Double-click on degrib-install.exe to install the program.  
A window will appear; click on the Install button and 
accept the defaults for the installer.

Once done, download the program from here:  
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/download.php

This page provides several different versions of the same product.  
For this tutorial, you will focus on the Microsoft Windows version.  
Click on degrib-install.exe and select Save. Specify the directory 
path for the program as c:/ndfd and copy the .exe into that folder.  
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Forecast Waveheight

Download: Double-click on tkdegrib (aka NDFD GRIB2 Decoder) to start the program.

Then click on the Download tab and expand the NDFD 
data set folder if it is not already open.

Choose the region of interest and expand the folder. 
Choose the days of interest and expand the folder. 

Data for each weather element can be downloaded by 
highlighting the entire region folder, or individual 
weather elements can be downloaded by holding down 
the Control key on the keyboard and highlighting one or 
more elements.

Click on Wave Height, and then click on either the 
Download by FTP or the Download by HTTP button 
(either will work) at the bottom of the window. 

Once downloading begins, there will be an indication in 
the Message Window that it is working. Also, after the 
download button is clicked, the light blue bar near the 
bottom of the window will show the progress of the data 
download. 
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This file contains important data in a binary format. Unfortunately, ArcGIS 
is unable to read this format, so the data must be converted into ESRI’s 
shapefile format, which you will do shortly.

View the data: Minimize this program and open Windows Explorer. Navigate to C:\ndfd\degrib18\data\ndfd\smissvly 
and notice that waveh.bin is stored in that directory.

Forecast Waveheight

Close Windows Explorer and return to the tkdegrib (aka 
NDFD GRIB2 Decoder) program.  At the bottom of the 
NDFD DataDownload and ImgGen program is a Generate 
Images button.  Click on this button to see different 
waveheight predictions within the waveh.bin file.
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View the data: Your default Web browser will open and reveal 
a site that shows the various wave height forecasts. To see the 
graphics, you may need to allow pop-ups to appear for this site.  
Simply click on the warning message at the top of the window 
and choose Allow Blocked Content.

Forecast Waveheight

You should be able to mouse over the times listed in the Wave Height 
column to see a graphic of predicted heights.
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View the data: Choose a day and time when the predicted 
storm position is close to landfall. This will probably reflect 
the highest waveheights (colors may display with reds and 
greens). Notice that the time values are expressed as “Zulu.” 
For guidance on how to convert to local time, refer to the 
appendix in the back of this tutorial.

For your purposes, select the data for Wednesday (12Z). 
This equates to noon at the Prime Meridian, and 7 a.m. in 
Eastern Daylight Time. Notice the red outline in the graphic.

Close the Web browser and return to the tkdegrib (aka 
NDFD GRIB2 Decoder) program again.

Forecast Waveheight
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Choose the time under the Valid Date field that will be 
closest to the forecasted landfall of the storm. 

An easy way to create an output shapefile inside the 
Output Filename window is to simply click on the 
Recommend button. Ideally, you should keep all of your 
regional files in the same directory (i.e., smissvly).

Specify the File Type as SHP (shapefile).

Specify the type of shapefile to be Large Polygon. 

Specify Round data to: 0 decimals.

Click the Generate .shp file button. This will create a 
new shapefile and copy it into your specified folder. 
Notice that it is in a different folder than the waveh.bin 
file.

Forecast Waveheight

Convert the data: Click on the GIS tab. This window lets users choose a file to convert to various GIS-friendly formats.  
Navigate to the directory of your .bin file. Double-click the waveh.bin file, and view the forecast times that match the 
graphics you just saw.

When finished, click on the window that reads Done. Minimize the program and open ArcMap.
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Add and symbolize the data: Start ArcMap by selecting Start > Programs > ArcGIS > ArcMap

Forecast Waveheight

Add data by clicking on the Add Data button 
found at the top of the ArcMap window. 
This will open a dialog window that lets users browse 
to their data.

Select the file and click Add. Notice the layer is now   
added to the top of the table of contents in ArcMap.

The data should now be symbolized to show the different 
forecasted waveheights.
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Add and symbolize the data: Double-click on the shapefile layer in ArcMap’s table of contents. This opens the Layer 
Properties dialog window. Select the Symbology tab to specify a predefined legend.

Click on the Import button to browse to predefined layer files.  

Forecast Waveheight
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Add and symbolize the data: In the Import Symbology 
dialog window, choose to Import symbology definition from 
an ArcView 3 legend file (*.avl). 

Click on the Browse button            and navigate to 
C:\ndfd\degrib17\arcview\poly_legend. 

Select waveheight.avl and click on the Open button.

Forecast Waveheight
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Add and symbolize the data: In the Import Symbology dialog 
window, the path to the .avl file will display. Click OK.

Take the default WaveHeight values listed in the Value Field 
drop-down menu.  

Click OK.

Forecast Waveheight
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Add and symbolize the data: Notice that a predefined set of 
symbols and values has been added under the Symbology tab. 
Values of “0” need to be set to transparent. Double-click on the 
symbol that is assigned to “0”.

The Symbol Selector dialog window opens to reveal different types of 
symbology to assign this symbol. Click on the Hollow symbol. 

Click OK to assign this transparency setting to “0” values.

Forecast Waveheight
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Add and symbolize the data: Collapse the symbols for 
this layer by clicking on the minus sign next to the 
layer’s name.  

Add a state boundary layer for reference purposes.  
Click on the Add Data button and browse to the 
following directory:  
C:\ndfd\degrib17\data\imageGen\shapefile

Select the states.shp layer for this example.

Click Add.

Forecast Waveheight
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Add and symbolize the data: The following Warning 
dialog will appear.  

Forecast Waveheight

This warning alerts the user that the data being added has 
a different spatial reference (projection system) than the 
NDFD layer currently in the table of contents. ArcMap’s 
data frame defaults to the spatial reference of the first layer 
added; however, other added layers having different spatial 
reference will automatically reproject to the original layer.  

This is known as “projection on the fly.” This message is normal and can be dismissed by clicking OK.
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Add and symbolize the data: At this point, 
you are ready to begin making maps of 
these data. 

Examples of maps that the NOAA Coastal 
Services Center has provided to members of 
FEMA in the past have been included.

Refer to the “Basics of Cartography” chapter 
at the end of this manual for additional 
information.

Forecast Waveheight
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Forecast Waveheight
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Forecast Waveheight
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Purpose: This type of map presents an estimate of the maximum wind speeds for a given area.  Wind speed is 
measured in miles per hour.

Source Data: This type of map uses the NOAA National Weather Service’s National Digital Forecast Database (NDFD), 
found at www.nws.noaa.gov/ndfd/. The National Weather Service (NWS) provides access to gridded forecasts of 
weather elements (e.g., cloud cover, maximum temperature) through the NDFD. This database contains a seamless 
mosaic of digital forecasts from NWS field offices working with the National Centers for Environmental Prediction 
(NCEP). The database uses a 5-kilometer national grid that covers the continental U.S. and separate grids that cover 
Hawaii, Alaska, the U.S. Virgin Islands, and Puerto Rico. Each 5-kilometer grid cell has forecast information, allowing 
users to retrieve specific forecasts by entering geographic coordinates. 

The World Meteorological Organization (WMO) has adopted Edition 2 of the gridded binary data (GRIB) code as a 
standard for sharing information. GRIB, Edition 2 (GRIB2), is involved in the NDFD in two ways. First, GRIB2 is the code 
form used to transmit gridded forecasts from contributing offices to the NDFD. Second, GRIB2 is one of the primary 
forms used to transmit the NDFD grids to NWS customers and partners. 

Download: Before working with NDFD data, users must first download the GRIB2 Decoder tool that allows access to the 
data. Learn more about GRIB2 Decoder by visiting this site: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/

Forecast Windspeed
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Forecast Windspeed

Download: Register for the DEGRIB program here: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php
At the top of the page, under step 1, click on the highlighted link to register and download the program.

Double-click on degrib-install.exe to install the program.  
A window will appear; click on the Install button and 
accept the defaults for the installer.

Once done, download the program from here:  
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/download.php

This page provides several different versions of the same product.  
For this tutorial, you will focus on the Microsoft Windows version.  
Click on degrib-install.exe and select Save. Specify the directory 
path for the program as c:/ndfd and copy the .exe into that folder.  
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Forecast Windspeed

Download: Double-click on tkdegrib (aka NDFD GRIB2 Decoder) to start the program.

Then click on the Download tab and expand the NDFD 
data set folder if it is not already open.

Choose the region of interest and expand the folder. 
Choose the days of interest and expand the folder. 

Data for each weather element can be downloaded by 
highlighting the entire region folder, or individual 
weather elements can be downloaded by holding down 
the Control key on the keyboard and highlighting one or 
more elements.

Click on Wind Speed, and then click on either the 
Download by FTP or the Download by HTTP button 
(either will work) at the bottom of the window. 

Once downloading begins, there will be an indication in 
the Message Window that it is working. Also, after the 
download button is clicked, the light blue bar near the 
bottom of the window will show the progress of the data 
download.
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This file contains important data in a binary format. Unfortunately, 
ArcGIS is unable to read this format, so the data must be 
converted into a shapefile.

Close Windows Explorer and return to the tkdegrib (aka NDFD 
GRIB2 Decoder) program.

View the data: Minimize this program and open Windows Explorer. Navigate to C:\ndfd\degrib18\data\ndfd\smissvly 
and notice that wspd.bin is stored in that directory.

Forecast Windspeed
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Choose the time under the Valid Date field that will be 
closest to the forecasted landfall of the storm. You may 
want to have this Windspeed map correspond to the 
same day and time of the Waveheight map in the 
previous module.

An easy way to name an output shapefile inside the 
Output Filename window is to simply click on the 
Recommend button. Ideally, you should keep all of your 
regional files in the same directory (i.e., smissvly).

Specify the File Type as SHP (shapefile).

Specify the type of shapefile to be Large Polygon. 

Specify Round data to: 0 decimals.

Click the Generate .shp file button.  This will create a 
new shapefile and copy it into your specified folder. 
Notice that it is in a different folder than the wspd.bin 
file.

Convert the data: Click on the GIS tab. This window lets users choose a file to convert to various GIS-friendly formats. 
Navigate to the directory of your .bin file. Double-click on the wspd.bin file to see a series of wind speed forecasts.

Forecast Windspeed

When finished, click on the window that reads Done. Minimize the program and open ArcMap.
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Add data by clicking on the Add Data button 
found at the top of the ArcMap window. 
This will open a dialog window that lets users browse 
to their data.

Add and symbolize the data: Start ArcMap by selecting Start > Programs > ArcGIS > ArcMap

Select the file and click Add. Notice the layer is now   
added to the top of the table of contents in ArcMap.

The data should now be symbolized to show the different 
forecasted wind speeds.

Forecast Windspeed
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Add and symbolize the data: Open the attribute table to see the records for this layer (right-click on the name of the 
layer and select Open Attribute Table).

The values represented in the WindSpd field are 
wind speeds measured in meters per second.  A 
new field will be added and calculated for wind 
speeds measured in miles per hour.

Forecast Windspeed
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Add and symbolize the data: Click on the Options button at the bottom right of the table and select Add Field. This 
opens a dialog window that allows you to specify the schema for the new field.

Specify the name of the new field as Miles_Hour and set 
the type of field to be Short Integer with a Precision of 3. 
Click OK to add the field.

Forecast Windspeed
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Add and symbolize the data: The new field is added, but it is empty. Right-click on the field name and select 
Calculate Values…

The following warning message will appear. Since you are 
not interested in starting an edit session for this operation, 
dismiss the dialog by clicking Yes.

Notice that the calculation expression is started within the Field Calculator 
dialog. Complete the formula as it is given in this example:    

[WindSpd] * 2.237  

Click OK to calculate the field.

Forecast Windspeed
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Add and symbolize the data: The values appear in the table and are now ready to be symbolized. Scroll through the 
table to see the range of wind speeds for this layer. Close the table when finished.

Double-click on the layer name in the table of contents.  
This will open the Layer Properties window.  Click             
on the Symbology tab to assign wind speed ranges to       
the polygons.

Change the “Show” group on the left of the window to the Quantities > 
Graduated colors category. Specify the Value field as Miles_Hour.  
Notice that a default classification is given.  

Forecast Windspeed
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Add and symbolize the data: Click on the Classify button to open the Classification dialog window. Set the 
Classification Method to Defined Interval. Change the Interval Size to 10. Click OK.

Choose a color ramp that is a logical progression             
from light to dark colors or, as in the example below,       
hot to cold colors.

Since you want the most dangerous wind speeds to be red, 
you need to reverse the order of these colors.  

Click on the Symbol field and select Flip Symbols. Click OK to see 
the new colors.

Forecast Windspeed
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Add and symbolize the data: Notice that the outline of the polygons appear distracting. Turn these off to see the wind 
speeds better.

Double-click on the layer to open its Layer Properties.  
Click on the Symbol header and select Properties for All 
Symbols.

Forecast Windspeed
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Add and symbolize the data: Change the Outline Color to No Color 
and click OK.  Click OK in the Layer Properties window to assign the 
change.

Notice that the different wind speeds are now easier 
to see.

Forecast Windspeed
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Add and symbolize the data: Collapse the symbols 
for this layer by clicking on the minus sign next to the 
layer’s name.  

Add a state boundary layer for reference purposes.  
Click on the Add Data button and browse to the 
following directory:  
C:\ndfd\degrib17\data\imageGen\shapefile

Select the states.shp layer for this example. 

Forecast Windspeed

Click Add.



Map Production 3-15

For FEMA
GIS Support Tutorial

Add and symbolize the data: The following Warning dialog will appear.  

This alerts the user that the data being added have a 
different spatial reference (projection system) than the 
NDFD layer currently in the table of contents.  

ArcMap’s data frame defaults the spatial reference to the 
first layer added; however, other added layers having 
different spatial reference will automatically reproject to 
the original layer.  

This is known as “projection on the fly.” This message is 
normal and can be dismissed by clicking OK.

Forecast Windspeed
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Add and symbolize the data: Click and drag the windspeed layer to the top. Double-click on the layer to open its Layer 
Properties window, and set the transparency so that you can see the state layer below it.  

Click on the Display tab, and change the Transparency to 40%. 

Click OK to see the change take effect.

At this point you are ready to begin making a map. The 
following example shows what the NOAA Coastal Services 
Center has provided to members of FEMA in the past.

Refer to the “Basics of Cartography” chapter at the end of this 
manual for additional information.

Forecast Windspeed
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Forecast Windspeed
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Purpose: This type of map presents a spatial and temporal precipitation forecast that predicts the potential amount of 
future precipitation for a specified region. The Southeast River Forecast Center (SERFC) uses the National Weather 
Service (NWS) Hydrometeorlogical Prediction Center’s 5-day quantitative precipitation forecast (QPF) and makes 
minor changes based on the knowledge of local forecasters. QPF products are created by adding the prediction 
center’s 6-hour QPFs for Days 1-3 (a total of 12 6-hour periods) to a 48-hour forecast for Days 4-5 prepared by NWS’s 
medium-range forecasters. This forecast is issued twice per day, once at 7:00 a.m. Eastern Daylight Time/Eastern 
Standard Time (EDT/EST) (11Zulu time [Z]/12Z) and again at 7:00 p.m. EST/EDT (23Z/00Z). Both forecasts are valid 
from the beginning of Day 1 through the end of Day 5, with the later issuance offset by 12 hours. For example, a 
forecast prepared at 7:00 a.m. EDT/EST on September 2, 2004, would be valid for the 120-hour period from 12Z 
September 2, 2004, through 12Z September 7, 2004. For more information on Zulu Time see the Appendix.

Source Data: This type of map uses the NOAA National Weather Service’s National Digital Forecast Database 
(NDFD), found at www.nws.noaa.gov/ndfd/. NWS provides access to gridded forecasts of weather elements (e.g., 
cloud cover, maximum temperature) through the NDFD. This database contains a seamless mosaic of digital forecasts 
from NWS field offices working with the National Centers for Environmental Prediction (NCEP). The database uses a 
5-kilometer national grid that covers the continental U.S. and separate grids that cover Hawaii, Alaska, the U.S. Virgin 
Islands, and Puerto Rico. Each 5-kilometer grid cell has forecast information, allowing users to retrieve specific 
forecasts by entering geographic coordinates. 

The World Meteorological Organization (WMO) has adopted Edition 2 of the gridded binary data (GRIB) code as a 
standard for sharing information. GRIB, Edition 2 (GRIB2), is involved in the NDFD in two ways. First, GRIB2 is the 
code form used to transmit gridded forecasts from contributing offices to the NDFD. Second, GRIB2 is one of the 
primary forms used to transmit the NDFD grids to NWS customers and partners. Users should note that this should be 
considered an experimental product at the time of this writing (March 2006).

120-Hour Quantitative Precipitation Forecast
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Download Data: Open a Web browser and connect to the 
FTP site that contains the GRIB data. Type the following 
address:

ftp://ftp.hpc.ncep.noaa.gov/grib/

Once you are connected, open a folder that corresponds 
with the date of QPF data you want to access. 

Scroll to the bottom of the list of GRIB files and select the 
one that begins with 120 (i.e., p120_2005082812f120.grb).

This represents the cumulative amount of rain for the next 
five days beginning at noon of August 28, 2005.

Double-click on the file to begin the download process.

120-Hour Quantitative Precipitation Forecast
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Download Data: If using Microsoft’s Internet Explorer, you will 
receive the following window. Click on the Save button and 
navigate to a folder on your hard drive (i.e., C:\GRIB_Data)

Open Windows Explorer to see the file. Because ArcGIS 
does not read this format, you must convert the file to the 
ESRI shapefile format.

120-Hour Quantitative Precipitation Forecast
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Download Software: Before working with NDFD data, you must first download the GRIB2 Decoder tool that allows 
access to the data. Learn more about GRIB2 Decoder by visiting this site: 
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/

Register for the DEGRIB program here: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php

Once finished, download the program: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/download.php

This page provides several different versions of the same product. For this tutorial, you will focus on the Microsoft 
Windows version. Click on degrib-install.exe file and select Save. Specify the defaults to begin the installation. This 
program will create c:/ndfd and install the necessary files into that folder. Once the installation is finished, you should 
have a program group like the one below.

Double-click on tkdegrib (aka NDFD GRIB2 
Decoder) to start the program.

120-Hour Quantitative Precipitation Forecast
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Download: In the main program window shown on the 
right, click on the GIS tab. 

Next, click on the Browse button at the top and navigate 
to the folder where you copied the GRIB data. Do you 
remember its name?

This file contains important Quantitative Precipitation 
Forecast (QPF) data in binary format. Unfortunately, ArcGIS 
is unable to read this format, so the data must be converted 
to a shapefile.

120-Hour Quantitative Precipitation Forecast
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Convert the data: Select the .grb file that was created on 
August 28, 2005 (20050828), at noon (12) Greenwich 
Mean Time, forecasting (f) the cumulative precipitation 
amount in 120 hours.

Next, specify where you would like to have the converted 
shapefile written. In this example, you will click on the 
Recommend button and take the default directory and 
filename.  

Specify that the new shapefile contains Large Polygons.

Specify Round data to: 0 decimals.

Click on the Generate .shp file button.

Click on the message box when the conversion is Done.

When finished, minimize the program and open ArcMap to 
add this layer and begin making a map that explains what 
the data are describing.

ArcMap can be started by selecting Start > Programs > 
ArcGIS > ArcMap.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Add the layer by clicking on 
the Add Data button         found at the top of the ArcMap 
window. This starts a dialog box that lets users browse to 
their data. Click on the layer to select, and click the         
Add button.

The data need to be symbolized to show the amount of precipitation 
expected in the area during the next 120 hours.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Double-click on the 
shapefile layer in ArcMap’s table of contents. This opens 
the Layer Properties dialog box. Select the Symbology 
tab, and click on the Quantities > Graduated Color 
category to specify a classification system.  

Set the field value to APCP (Accumulated Total 
Precipitation), and click on the Classify button.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Change the 
classification method to Defined Interval. Set the 
Interval Size to 1 (inch of rain) and click OK to make the 
change.

Assign a logical color ramp to the rainfall amounts in the 
Symbology tab by right-clicking on the color ramp and 
choosing Graphic View. This gives a textual 
description of the color ramp.

Select a color ramp that is a logical progression from light to dark 
colors, or, as in the example on the left, Precipitation. Next, flip the 
color of the symbols so that the reds are assigned to the higher values. 
Click on the Symbol field and select Flip Symbols. Click OK.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Notice that the outlines of the polygons appear distracting. Turn these off to see the 
precipitation amounts better.

Double-click on the layer to open its Layer Properties 
again. Click on the Symbol header and select Properties 
for All Symbols.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Change the Outline Color to no color and click OK.  Click OK in the Layer Properties 
window to assign the change.

Notice that the different precipitation amounts are now 
easier to see.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Collapse the symbols for this layer by clicking on the minus sign next to the layer’s 
name. Zoom into an area of interest. 

Notice that the layer is now properly symbolized with specific 
colors assigned to precipitation amounts. Also note that the 
units of measure is in inches.

To clearly see the political areas affected by this rainfall, you 
must add a new layer. Minimize ArcMap and open a Web 
browser. Visit the AWIPS homepage to download these 
data: www.nws.noaa.gov/geodata/

120-Hour Quantitative Precipitation Forecast

This site serves different base layer data for use in a GIS. Scroll down the page 
and find the County Libraries section.

Click on the file named Counties at 1:100k.



Map Production 4-13

For FEMA
GIS Support Tutorial

Add and symbolize the data: This site provides free 
county boundary data at 1:100,000 scale, which will 
be suitable for our mapping purposes. 

Scroll down and click on the Download Compressed 
Shapefile link. Save this file to your GRIB_Data 
folder. This 52 MB file is large and will take some time 
to save.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: Once the download finishes, you 
should open the .zip file with a compression utility package.

Extract all three files from the .zip file and save them to the 
c:\GRIB_Data folder.   

Open ArcMap back up and add the new county boundary layer. 

Drag the county boundary layer below the QPF layer.  
Make the QPF layer partially transparent so that both 
layers are visible.  

To do this, double-click on the QPF file to open Layer 
Properties. Select the Display tab and set the 
Transparency to 40%. Click OK to make the change.

120-Hour Quantitative Precipitation Forecast
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Add and symbolize the data: You may want to set the first class (0-1 inches) to be transparent. Right-click on the 
symbol that represents that class and select No Color.

At this point you are ready to begin making a map. The 
following examples show what the NOAA Coastal Services 
Center has provided to members of FEMA in the past.

120-Hour Quantitative Precipitation Forecast

Refer to the “Basics of Cartography” chapter at the end of 
this manual for additional information.
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120-Hour Quantitative Precipitation Forecast
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120-Hour Quantitative Precipitation Forecast
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Purpose: This type of map presents an estimate of the amount of rainfall during one or more days. This amount is 
measured in inches.

Source Data: National Hurricane Center (NHC) and local weather information, forecast tracks, and evacuation time 
calculations can be plotted manually, but this can be an onerous task during an emergency. A computer program called 
HURREVAC automatically tracks this information and displays the results graphically. The computer program can be 
obtained from county, local, and state emergency management offices. (Please note that this program is not 
available to the general public.)

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast

HURREVAC updates current and forecast storm data and then 
displays the track of the storm in various formats. Using 
Hurricane Evacuation Study (HES) data, it considers the 
potential for storm surge and calculates evacuation times by 
considering storm speed and intensity. HURREVAC can also be 
used as a "what if" tool to help emergency managers determine 
courses of action for different storm characteristics.

Download: This tutorial assumes that users of HURREVAC 
have already installed the software and have some idea of how  
it works.
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Access the data: Begin using HURREVAC by 
going to Start > Programs > HURREVAC2000.  
Once the program opens, click on the Auto 
Download Latest button.

Once the data finishes downloading, click Exit to 
close the window.

Click on the Load Storm File button to access data 
for a specific tropical storm.

The following dialog window will open. Navigate to the c:\Program 
Files\Hurrevac2000\data folder. Click on the storm name (first letter in 
name_year of storm). Click on the Load File button.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Access the data: To view HPC Rainfall forecasts for a given day, click on the HPC Rain Forecast button.                  
This will display the areas expecting rain for that day.

Right-click on this button to show additional days 
afterwards. To zoom in closer to an area of 
interest, simply click and drag your cursor to make 
a frame around the area.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Access the data: To select and output the data presented inside HURREVAC to an ESRI shapefile, simply select     
File > Export Field(s) to GIS File.  

Click on a field type and click the Continue button. For this example, the 
HPC rainfall forecast for Day 1 will be selected.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Access the data: A dialog window will appear that asks for the folder to save the downloaded shapefile. Specify an 
existing folder, or create a new one (i.e., C:\HPC_Data).  

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast

Provide a logical name for your shapefile and click 
Save. Ideally, you should try to record the date for 
which the HPC data are valid.
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View the data: Add the layer by clicking on the Add Data button              found at the top of the ArcMap window. This 
brings up a dialog window that lets users browse to the data.

Select the HPC layer and click Add. The layer now 
appears at the top of ArcMap’s table of contents.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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View the data: Repeat this process for the other days you wish to display. Notice that three consecutive days have 
been displayed in the table of contents below.  

To determine the amount of rain in inches that are 
predicted for these areas, you must add a new field to each 
layer and calculate them. 

Right-click on the earliest layer and select Open    
Attribute Table.  

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast

When the table opens, look at the bottom right corner and 
select Options > Add Field.
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Calculate rainfall: The Add Field dialog window will appear. Specify the name of the field as Inches.

In the table, right-click on the Inches field. In the context 
menu, select Calculate Values...

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast

Specify the Field Type as Double (or “double precision”)

Specify the Precision (or the number of digits to be assigned for each number) 
to be 10, and the Scale (or the number of decimal places) to be 2.  

Click OK to create the field.
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Calculate rainfall: A warning message will appear. This alerts you to the fact that any calculations made to this field will 
be permanent. Click Yes to dismiss this message.

In the Field Calculator dialog window, notice that the calculation 
expression is started for you:  “Inches = “

Simply complete the expression by double-clicking on the field called ID, 
click on the “multiply by” mathematical operation that looks like an 
asterisk, and then type .01. This operation will multiply the ID value of 
each record by 0.01 to determine rainfall amounts in inches.

Once the expression is developed, click OK.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: The rainfall values now appear in the table as amounts in inches. Close this layer’s table and 
repeat the same steps for the two other layers.

Once all three layers have a field named Inches in 
their attribute tables, you can add them together to 
find cumulative amounts of rainfall for given areas 
during those three days.

To perform this step, you must convert the polygon 
layers to raster layers using an ArcGIS extension 
known as Spatial Analyst.

Begin by adding the Spatial Analyst toolbar. Click on 
View > Toolbars > Spatial Analyst. You will see 
the toolbar appear in the application.

You can drag and dock this toolbar to the ArcMap window or let it 
“float” around in ArcMap. You should now enable the extension by 
clicking on Tools > Extensions.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Once the Extensions window appears, check on Spatial 
Analyst to enable the extension. Click Close.  

Click on the Spatial Analyst menu from the toolbar and 
select Convert > Features to Raster. This will convert 
the polygon layers to raster layers for analysis.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Each polygon layer will be converted into a raster. Select Spatial Analyst > Convert > Features to 
Raster. The following window will appear. Select one of the polygon layers from the Input Features drop-down menu.

Specify Inches in the Field drop-down menu, because these are the 
values we want to transfer over for our raster cells. Change the Output 
cell size to be 0.10.  These units are in geographic coordinates, since the 
source data are also unprojected. Specify an output folder and file name 
for the new raster. Ideally, you should consider using the same folder that 
is used for the feature layers. You should also consider keeping the 
same naming convention for the raster as was used for the feature data.

Click OK. The raster layer is created and added to ArcMap’s table of 
contents.

Repeat this process for the other two feature layers until all three have 
been converted.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Once the layers are converted, turn off the features and turn on all three rasters. Order them as shown 
below. Each can be considered a valuable layer, but you will add them together to determine how much rain will fall in the 
next three days.

Before you can add up the values of the cells, you have to 
reclassify them, or group them into classes of like value. 
Select Spatial Analyst > Reclassify. In the dialog box, 
select the earliest date as the input raster, and click on the 
Classify button.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Select Defined Interval as the classification method. Change the Interval Size to 1 (inch of rain). Click 
OK to set the classification.

Notice that the values have changed in the Reclassify 
window. Scroll down to the bottom and manually change 
the NoData value to 0 as in the example below. Click OK 
to create the temporary layer. It will be added to the table 
of contents. 

Repeat this process for the other two layers. Make sure whole values are 
present in the New Values column.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Your reclassified layers will look similar to the example below. Don’t be concerned with the colors at 
this time, since we will assign logical colors after the rasters are added.

When finished, click OK. 

Before the layers can be added, the Analysis Extent has to 
be set. This is what ArcMap determines to be the area that 
everything falls inside. If the extent is not set properly, data 
can be clipped off and omitted.

Select Spatial Analyst > Options. Click on the Extent tab 
and specify Same as Display for the Analysis Extent.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Once all three layers have been reclassified, they are ready to be added.  

Select Spatial Analyst > Raster Calculator.  

Double-click each layer to place it in the expression window, and 
separate each with a “plus sign” as shown to the right.  

When finished, click on the Evaluate button to start the             
addition process.  

The following message box may appear because your raster layers do 
not have a projection system assigned to them. For now, dismiss this 
message by clicking Yes.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: The resulting Calculation layer may look something like the example below.  

Assign a logical color ramp to the rainfall amounts by 
opening the Layer Property window for the Calculation 
layer. Select the Symbology tab and choose the Unique 
Values category listed on the left. Right-click on the color 
ramp and choose Graphic View. This gives a textual 
description of the color ramp.

Select a color ramp that is a logical progression from light to 
dark colors, or, as in the example on the left, Precipitation. 
Next, flip the color of the symbols so that the reds are 
assigned to the higher values. Click on the Symbol field and 
select Flip Symbols. Click OK.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Right-click on the first cell to change “0” from blue to No Color.

Add a county boundary layer from the            
AWIPS_Data folder.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall:  Move the county boundary layer below the three-day HPC Rainfall Forecast layer.

Make the HPC layer partially transparent so that both 
layers are visible. To do this, double-click on the layer 
to open its Properties window. Select the Display tab 
and specify the Transparency at 40%. Click OK to see 
the result.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Calculate rainfall: Zoom to an area of interest and see the results.

NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast

At this point you are ready to begin making a map. An 
example has been included of what the NOAA Coastal 
Services Center has provided to members of FEMA in 
the past.  

Refer to the “Basics of Cartography” chapter at the end 
of this manual for additional information.
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NOAA Hydrometeorological Prediction Center (HPC) Rainfall Forecast
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Purpose: This type of map displays precipitation estimates for given areas using multiple sensors.

Source Data: These data are created using multiple inputs that include the following:

• High-resolution Parameter-Elevation Regressions on Independent Slopes Model (PRISM) data derived from 
National Oceanic and Atmospheric Administration (NOAA) Cooperative Stations. These data are the most 
detailed, highest-quality spatial climate data sets currently available. 

• Process 1 (P1) offers the best estimates of gridded precipitation fields currently available in an operational 
environment. When compared to one another, P1 and PRISM data offer detailed insights into the distribution of 
rainfall across a 4 x 4 kilometer scale. Using these products, users can capture localized departures that are 
often lost when using regionalized climate and drought maps. 

• SNOTEL (for SNOwpack TELemetry), operated by the Natural Resources Conservation Service (NRCS). This 
automated system is used to collect snowpack and related climatic data in the Western United States.  
SNOTEL has reliably and efficiently collected the data needed to produce water supply forecasts and to 
support the resource management activities of NRCS and others. 

• U.S. Geologic Survey (USGS) Digital Elevation Models (DEM). 

• Sets of rules, decisions, and calculations used to simulate the thought process of a climatologist in generating 
spatial climate maps. These rules account for increased precipitation with elevation, rain shadows, and coastal 
locations. The further a given location is from an observation site, the more these rules influence a given 
climate parameter.   

24-Hour Stage III Rainfall
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Download: Users wanting to download this kind of spatial 
data should visit the NWS Precipitation Analysis Web site at 
www.srh.noaa.gov/rfcshare/precip_analysis_new.php.  

Begin by specifying the region of interest. You can either 
click on the map to zoom closer to an area or specify a state 
from the drop-down list at the bottom.

For this module, you will look at the observed precipitation 
amounts in the last 24 hours for Louisiana.

Specify that you want the Current Data for this day.

Select Louisiana from the drop-down list. The graphic map 
will change to reflect the data for this state.

24-Hour Stage III Rainfall
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Download: Your display will change to show the state of 
interest and the amount of recorded precipitation from the 
last 24 hours.

You will download these data and bring them into your GIS 
for display. Click on the Download tab to begin this process.

24-Hour Stage III Rainfall
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Download: The following window should appear. Click the 
Download Now button to begin the process.

A File Download dialog window will prompt you to decide 
what to do with your data. Click the Save button. Create  
a new folder (i.e. C:\precip_data) and copy the file into 
that location.

Once the download completes, 
click on the Open button.

24-Hour Stage III Rainfall
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Download: You will now find a .tar file copied to this folder. 
This is a compressed file that contains other files. You will 
need to use a file uncompression software (such as Winzip 
or PKZip) to extract the other files.

Once these files are extracted, they make up a “shapefile” 
(with .dbf, .shx, and .shp extensions).

24-Hour Stage III Rainfall
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Download: You should now see the following files in 
your directory. Once the shapefiles are 
uncompressed, you can view them in ArcGIS.

An important thing to note: there are two cycles of precipitation shapefiles. The first (preliminary) is 
updated between 9:30 and 10:00 a.m. Central Daylight Time (CDT) (1430 zulu [z]-1530z). The final 
version takes into account late rain gage reports and adjustments to radar data. This version comes out 
between 4:00 to 5:00 p.m. (CDT) (2100z – 2200z). 

24-Hour Stage III Rainfall
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Add and symbolize the data: Add the layer by clicking on the Add Data button           found at the top of the ArcMap 
window. This opens a dialog box that lets users browse to their data.

Once you have selected the shapefile, click Add.

Now select just the points in the study area. Use the Feature 
Selection tool             to click and drag an area.

24-Hour Stage III Rainfall
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Add and symbolize the data: After the points are selected, export them to a new layer. Right-click on the name of the 
shapefile and select Data > Export Data.

In the dialog window, specify that you will only export the 
Selected features (which is the default), use the same 
coordinate system as the shapefile (again, the default), and 
browse to a folder and specify a name for the new layer.  

Please remember to include the date from the original layer 
in the name of the new layer so that others will know when 
the data were captured.

Click OK when finished. Add the new layer into ArcMap, and turn off 
the original one.

24-Hour Stage III Rainfall
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Add and symbolize the data: The data should be 
symbolized to show precipitation amounts for the area. 
You will now download an associated ArcView Legend 
(.avl) file that will provide the proper symbology.

Going back to the Southern Region Headquarters Web 
site, you will specify the legend file containing symbology.  
Click on the Download Now button.

Save the .avl into the same Precip_Data folder and take 
the default name given to the .avl. Click Save. Once the 
download is complete, simply close the message window.

Open Windows Explorer and navigate to where the .avl file 
was saved. Notice that the zip utility may have appended 
“.txt” onto the end of your .avl file.  Simply remove the “.txt” 
portion and ArcGIS will recognize the file as an ArcView 
legend file.

24-Hour Stage III Rainfall
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Add and symbolize the data: Right-click on the exported layer and select Zoom to Layer. Double-click on the 
shapefile layer in ArcMap’s table of contents. This opens the Layer Properties dialog window. Select the Symbology 
tab to specify a predefined legend.

Click on the Import button to browse to the .avl file.  

24-Hour Stage III Rainfall
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Add and symbolize the data: In the Import Symbology dialog window, choose to Import symbology definition from an 
ArcView 3 legend file (*.avl). Click on the Browse button               and navigate to C:\Precip_Data. Select the 
NWS_Precip_Legend.avl file. Click OK.

In the Import Symbology Matching Dialog window, change the Value Field to 
GLOBVALUE. Click OK. The points will now symbolize according to the rainfall 
amounts in the .avl.

24-Hour Stage III Rainfall
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Add and symbolize the data: The predefined symbology will appear complete with rainfall amounts measured in inches.  
However, the size of each point is too great for your cartographic purposes. Click on the Symbol column heading and 
select Properties for All Symbols. Here you can reduce the size of all of the points. Select 10 and click OK.

Click OK to assign these values.

To clearly see the political areas affected by this rainfall, you 
must add a new layer. Minimize ArcMap and open a Web 
browser.  

24-Hour Stage III Rainfall
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Add and symbolize the data: Visit the AWIPS 
home page to download these data:  
www.nws.noaa.gov/geodata/

This site serves different base layer data for use in a 
GIS. Scroll down the page and find the County 
Libraries section.

Click on the file named Counties at 1:100k.

24-Hour Stage III Rainfall
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Add and symbolize the data: This site provides free 
county boundary data at 1:100,000 scale, which will be 
suitable for our mapping purposes. 

Scroll down and click on the Download Compressed 
Shapefile link. Save this file to your Precip_Data 
folder. This 52-megabyte file is large and will take 
some time to save.

24-Hour Stage III Rainfall
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Add and symbolize the data: Once the download finishes, you should 
open the .zip file with a compression utility package.

Extract all three files and save them to the c:\Precip_Data folder.   

Open ArcMap back up and add the new county boundary layer.

Move the county layer below the 24-hour precipitation layer. Make 
the precipitation layer partially transparent so that both layers are 
visible. To do this, double-click on the layer to open its Properties 
window. Select the Display tab and specify 40%. Click OK to see 
the result. 

At this point you are ready to begin making a map. Several 
examples have been included to show what the NOAA Coastal 
Services Center has provided to members of FEMA in the past. 
Refer to the “Basics of Cartography” chapter at the end of this 
manual for additional information.

24-Hour Stage III Rainfall
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24-Hour Stage III Rainfall
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24-Hour Stage III Rainfall
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Purpose: This type of map displays cumulative precipitation estimates for a range of dates for given areas               
using multiple sensors.

Source Data: These data are created using multiple inputs that include the following:

•

 

High-resolution Parameter-Elevation Regressions on Independent Slopes Model (PRISM) data derived from 
National Oceanic and Atmospheric Administration (NOAA) Cooperative Stations. These data are the most 
detailed, highest-quality spatial climate data sets currently available. 

•

 

Process 1 (P1) offers the best estimates of gridded precipitation fields currently available in an operational 
environment. When compared to one another, P1 and PRISM data offer detailed insights into the distribution of 
rainfall across a 4 x 4 kilometer scale. Using these products, users can capture localized departures that are 
often lost when using regionalized climate and drought maps. 

•

 

SNOTEL (for SNOwpack TELemetry), operated by the Natural Resources Conservation Service (NRCS). This 
automated system is used to collect snowpack and related climatic data in the Western United States.  
SNOTEL has reliably and efficiently collected the data needed to

 

produce water supply forecasts and to 
support the resource management activities of NRCS and others. 

•

 

U.S. Geologic Survey (USGS) Digital Elevation Models (DEM). 

•

 

Sets of rules, decisions, and calculations used to simulate the thought process of a climatologist in generating 
spatial climate maps. These rules account for increased precipitation with elevation, rain shadows, and coastal 
locations. The further a given location is from an observation site, the more these rules influence a given 
climate parameter.   

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Download: Users wanting to download this kind of spatial data should visit the NWS Precipitation Analysis Web site at 
www.srh.noaa.gov/rfcshare/precip_analysis_new.php.  

Begin by specifying the region of interest. You can either click

 

on the map to zoom closer to an area or specify a state from 
the drop-down list at the bottom.

For this module, you will look at the observed precipitation 
amounts in the last seven days for Florida.

Change the timeframe of observation to 7 days. The graphic 
map will change to reflect the cumulative precipitation amounts.

Leave the Product as Observed.

Select Florida from the drop-down list. Again, the map will 
change to reflect the data for that state.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Download: Your display will show the state of interest 
and the amount of recorded precipitation from the last 
seven days.

To create a cumulative rainfall estimate, you will specify 
multiple dates for your study area. Hurricane Wilma 
made landfall on October 24, 2005. You will download 
historical data from this site and bring it into your GIS for 
display. Click on the Download tab to begin this 
process.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Download: The following window should appear. You 
will download a shapefile for the Continental U.S. for 
October 23, 2005. Click the Download Now button to 
begin the process.

A File Download dialog window will prompt you to decide 
what to do with your data. Click the Save button. Create a 
new folder (i.e., C:\cumulative_rainfall), and copy the file into 
that location.

Once the download completes, click 
on the Open button.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Download: You may receive the following dialog box. Click Yes to decompress the file into a temporary folder and open 
it.

Once these are extracted, they make up a “shapefile”

 

(with 
.dbf, .shx, and .shp

 

extensions).

You will now find a .tar file copied into this folder. This is a

 

compressed file that contains other files. You will need to use a 
file uncompression software (such as Winzip or PKZip) to extract

 

the other files.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Download: You should now see the following files in 
your directory. Once the shapefiles are uncompressed, 
you can view them in ArcGIS.

Repeat these steps for two other dates (i.e., October 24 
and 25, 2005). Once these shapefiles are 
uncompressed, add them into ArcMap.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Click on the Add Data button            to add the three shapefiles.

Add a county boundary layer to see how these data overlay.

Add the data: Open ArcMap by clicking on Start > Programs > ArcGIS > ArcMap.

Zoom to an area of interest. In this example, you will look at the 
southwestern coast of Florida.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: The data should be 
symbolized to show precipitation amounts for the area.  
You will now download an associated ArcView Legend 
(.avl) file that will provide the proper symbology.

Going back to the NWS Precipitation Analysis Web site, 
you will specify the legend file containing symbology. Click 
on the Download Now button.

Save the .avl into the same Cumulative_Rainfall folder and 
take the default name given to the .avl. Click Save. Once the 
download is complete, simply close the message window.

Open Windows Explorer and navigate to the folder you saved 
the .avl file in. Notice that the zip utility may have appended 
“.txt”

 

onto the end of your .avl file. Simply remove the “.txt”

 

portion, and ArcGIS will recognize the file as an ArcView 
legend file.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: To clearly see the 
political areas affected by this rainfall, you must add 
a new layer.  

Open a Web browser and visit the AWIPS 
homepage: www.nws.noaa.gov/geodata/

This site serves different base layer data for use in a 
GIS. Scroll down the page and find the County 
Libraries section.

Click on the file named Counties at 1:100k.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: This site provides free 
county boundary data at 1:100,000 scale, which will be 
suitable for your mapping purposes. 

Scroll down and click on the Download Compressed 
Shapefile link. Save this file to your 
Cumulative_Rainfall folder. This 52-megabyte file is 
large and will take some time to save.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Once the download finishes, you should 
open the .zip file with a compression utility package.

Extract all three files and save them to the c:\Cumulative_Rainfall folder.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate

Open ArcMap back up and add the new county 
boundary layer.

Move the county layer below the cumulative 
rainfall layers.  
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Add and symbolize the data: Double-click on one of the Stage III layers in ArcMap’s table of contents. This opens the 
Layer Properties dialog window. Select the

 

Symbology tab to specify a predefined legend.

Click on the

 

Import button to browse to the .avl file.  

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: In the Import Symbology dialog window, choose to

 

Import symbology definition from 
an ArcView 3 legend file (*.avl). Click on the Browse button               and navigate to C:\Cumulative_Rainfall. Select 
the nws_precip_new_legend.avl file. Click OK.

In the Import Symbology Matching Dialog window, the Value Field should read 
Globvalue. Click OK. The points will now symbolize according to the preset 
rainfall amounts contained in the .avl.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: The predefined symbology will appear complete with rainfall amounts measured in inches.  
Click OK to assign these values.

Repeat the symbolization operation for each of the Stage III 
shapefiles.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: To make visualization easier, minimize the symbology of each layer by checking on the 
minus (“-”) sign next to each one.  

To combine these three layers, you must first convert them into 
raster layers. This is done through the use of the Spatial Analyst 
extension. Enable Spatial Analyst by clicking on the Tools menu 
and selecting Extensions…

Turn on Spatial Analyst and Close the Extension window. Now add the Spatial 
Analyst toolbar by clicking on the

 

View menu and selecting Toolbars > Spatial 
Analyst. The toolbar will appear and can be docked to the ArcMap window.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Click on one of the rainfall layers to highlight it. Click on the Spatial Analyst menu and 
select Convert > Features to Raster…

In the dialog box, specify the selected layer to convert. 
In the Field drop-down menu, retain Globvalue.

Change the Output cell size to 0.05.

Specify a folder for the new raster layer.  Remember 
that rasters are limited to 13 characters for their 
names―and that you should include the date of data 
capture in the name.

Click OK when you are finished. This will create the new raster from the

 

shapefile, and ArcMap will add it automatically into the table of contents and 
turn it on.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: The converted raster layer should look like the example below. Turn off the point 
shapefiles to view the raster.

Repeat this conversion process for the other two layers. 
Be sure to specify the same cell size (0.05) for all rasters.

When this work is finished, the layers will probably not look 
very impressive. You need to remove any null values.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate



Map Production 7-18

For FEMA
GIS Support Tutorial

Add and symbolize the data: Use the Raster Calculator found inside the Spatial Analyst menu and develop the 
following expression to remove null values:
con(isnull ([stg3_20051023 - stg3_20051023]), 0, ([stg3_20051023 - stg3_20051023]))

This is a pretty complicated expression to execute properly. Pay

 

close attention to the parentheses, brackets, and spaces 
throughout. When you have the expression developed, click 
Evaluate.

The resulting raster will look similar to this example. Open its

 

Layer 
Properties window and select the Symbology tab.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Click on the Classified option under the Show field.

Change the Classification system from Natural Breaks to 
Defined Interval by clicking on the Classify button.

Change the Interval Size to 1.

Click

 

OK when finished.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Change the color ramp to a red-to-blue graduation.

Flip the symbols so that the lowest rainfall amounts are 
coded blue and the highest areas are red. Click on the 
Symbol field and select Flip Colors. Click OK.

The raster should symbolize to look like the example to the 
left. Right-click on the class of values ranked 0 - 1 and set 
them to No Color.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: The resulting raster should look like the example below. Repeat

 

the process for the other 
two layers until you have a series of “Calculation”

 

rasters.

It makes sense to rename the calculated rasters by adding 
their collection dates.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Now add the individual rasters together by using the Raster Calculator again.

Build the expression to look like the example to the right, where each 
raster is added together. When finished, click Evaluate.

The resulting raster should look like this example. Go into its 
Layer Properties and Symbolize it like the others before.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Add and symbolize the data: Notice that all rainfall values for the rasters have been summed and the result appears in 
this example. You should now save this layer so that it becomes permanent.  

Right-click on the Calculation layer and select Make 
Permanent. In the dialog box, specify a new name for the 
raster, and save it into the Cumulative_Rainfall folder.  
Click Save.

Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate

At this point you are ready to begin making a map. Several examples have been included to show what the NOAA Coastal 
Services Center has provided to members of FEMA in the past. Refer to the “Basics of Cartography”

 

chapter at the end of 
this manual for additional information.
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Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Cumulative Rainfall – Stage III Multi-Sensor Precipitation Estimate
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Purpose: This type of map presents the predicted amount of storm surge from a tropical cyclone event. The Sea, Lake, 
and Overland Surges from Hurricanes (SLOSH) model is currently the primary tool used by the federal government to 
evaluate the threat from storm surge. 

Source Data: SLOSH is a computerized model run by the National Weather Service to estimate storm surge heights 
from historical, hypothetical, or predicted hurricanes. The model creates its estimates by assessing the pressure, size, 
forward speed, track, and wind data from a storm. Graphical output from the model displays color-coded storm surge 
heights for a particular area. The calculations are applied to a specific locale's shoreline, incorporating the unique bay 
and river configurations, water depths, bridges, roads, and other physical features. 

The geographic coverage of the SLOSH model currently includes all of the U.S. East and Gulf coasts, as well as parts of 
Hawaii, Guam, Puerto Rico, and the Virgin Islands. With the SLOSH Display Program, a user can generate and extract 
GIS shapefiles for various storm scenarios, which can be exported and used in a mapping environment such as ArcMap. 

More information about the SLOSH program is found at www.nhc.noaa.gov/HAW2/english/surge/slosh.shtml.

SLOSH Model Run
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SLOSH Display Instructions: Install the current SLOSH Display Program that is distributed through the NOAA National 
Weather Service’s (NWS) Meteorological Development Lab (MDL). Once installation is complete, click on Start > 
Programs > SLOSH Package 1.33 > SLOSH Display.  

SLOSH Model Run

Once the program opens, click on the Change Basin menu and 
select Change Basin. Click on the basin that is forecast to be 
affected by the hurricane of concern. It may be necessary to step 
through this process for several adjoining basins because of 
forecast uncertainty. 

Hurricane Wilma struck the southwestern Florida coast on October 
24, 2005, as a Category 3 storm. For this tutorial, you will focus on 
this area.
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SLOSH Display Instructions: The following map will appear. 
Select the basin of interest by clicking on the elliptical graph on the 
map. You should see the corresponding basin name selected on the 
left (efmy Elliptical Fort Myers). Double-click on this name to change 
the appearance of the map.    

SLOSH Model Run

The new basin appears for your study area.
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SLOSH Display Instructions: After choosing a basin, click on the Select Storm menu and then on Select Storm. Once 
the dialog window appears, make sure the radio button for MEOW is selected. This will illustrate the “Maximum Envelope Of 
Winds” for the storm.

SLOSH Model Run

Under Direction, choose the direction in which the storm 
is forecast to be moving at the time of landfall. 

For Category, select the category or intensity that the 
storm is forecast to be at landfall. Select the next 
highest category if the storm is forecast to be on the 
cusp of one category and another. 

Finally, for Speed, select the closest speed at which the 
storm is forecast to be moving. Again, if necessary, 
round up if the storm is forecast to be moving at a 
speed somewhere in between the choices. 

Click Apply and then Close. 



Map Production 8-5

For FEMA
GIS Support Tutorial

SLOSH Display Instructions: Once the surge heights are displayed in the map, click File > Save to SHP.

SLOSH Model Run

If this option is not available in your version of the SLOSH 
Display Program, please contact one of these developers:

Arthur Taylor – (301) 713-1613, ext. 163 or 
Arthur.Taylor@noaa.gov

Wilson (Wil) Shaffer – (301) 713-1613, ext. 167 or 
Wilson.Shaffer@noaa.gov
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SLOSH Display Instructions: If you have enabled the SLOSH Display Program to save your data in the shapefile 
format, the following dialog box will open.  

SLOSH Model Run

You have the ability to change the directory that the data will be saved to. Simply 
click on the <..> in the grey area and navigate to a new location. For the purposes 
of this module, you will take the default location. Notice the naming convention 
that will be used for the shapefile; “ne315” represents a storm heading toward the 
northeast that strikes the shore as a Category 3 moving at 15 miles per hour.  

Click on the Done button. The next dialog window will open. You should simply 
take the default values given in the display and click OK. The shapefile of the 
SLOSH data for this area will copy into the given folder.
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Download the data: Should you not have access to saving the SLOSH data as a shapefile, you can download the most 
recent shapefiles from ftp://ftp.tpc.ncep.noaa.gov/users/surge.

This page will provide shapefiles that depict the latest SLOSH model runs. The formatting of the shapefiles follows the 
convention [letter of storm][advisory number]_[basin abbreviation].[file extension]. Download all the files (.shp, .shx, .dbf) 
for the latest advisory for each affected basin to your hard drive or network drive with the exception of the .rex and .gif 
files. A map will need to be created for each of the latest SLOSH model runs for each basin.

SLOSH Model Run
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View the data: Add the layer by clicking on the Add Data button          found at the top of the ArcMap window.  This 
brings up a dialog window that lets users browse to their data.

Select the SLOSH data that you want to work with 
and click Add. The layer now appears at the top of 
ArcMap’s table of contents.

SLOSH Model Run
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Work with the data: In ArcMap, go to the Selection pull-down 
menu and click on Select by Attribute.

1. Set the Layer to the SLOSH 
data that you are working on.

2. Make sure the Method is set 
to Create a new selection.

3. Under Fields, double-click on 
the field with the same name 
as your layer.

4. Single-click on the less than 
operator (<).

5. In the expression box, type in 
the number 99 at the end of 
the expression.

6. Make sure the Select by 
Attributes dialog box looks 
like the one pictured here and 
click OK.

SLOSH Model Run
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Add and symbolize the data: After the selection is made, right-click on the SLOSH layer and select the Data option from 
the context menu. From the Data menu select Export. Make sure Selected features is shown in the Export pull-down 
list. Use the same coordinate system as the layer’s source data, and specify a name and location where you would like 
the new shapefile to be created. Click OK.

When asked if you want to add the exported data to the map as a 
layer, click Yes.  

You have just created a new shapefile without the No Data value 
of 99.9 that was included in the original data downloaded from 
the National Hurricane Center.

Remove the original SLOSH data, leaving the layer you created 
in the last step.

SLOSH Model Run
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Add and symbolize the data: Double-click on the new SLOSH data layer to open the Layer Properties dialog. Click on 
the Symbology tab.  

In the Show menu, click on Quantities.

Under Quantities, make sure Graduated 
colors is selected.

Under Fields, change Value to the field that 
matches the name of your SLOSH layer.

You may get a dialog box that tells you that 
not all records are being used because the 
sample size is too small. Click OK.

Right-click on the Color Ramp. Click Graphic 
View from the available options. This 
changes the color ramp into a textual 
description of the color ramp.

Select the Spectrum-Full Bright color ramp.

SLOSH Model Run
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Add and symbolize the data: Click on the Symbol header and select Flip Symbols so that higher amounts of 
inundation are assigned darker reds.

Click Apply to assign the new color ramp.

Click again on the Symbol header.

Select the Properties for all Symbols option.

In the Symbol Selector dialog box, under 
Options, click on the Outline Color pull-down 
menu and select No Color.

Click OK and OK again to close the Layer 
Properties box and apply all of the changes 
you have made to the symbology of the 
SLOSH data layer.

This will remove the outline around each 
polygon and make the SLOSH data appear 
more continuous.

Click OK to make these changes in the view.

SLOSH Model Run
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Add and symbolize the data: You now have the SLOSH data symbolized in a meaningful way. You might want to add a 
state boundary layer for display purposes.

Click on the Add Data button and browse to the 
directory that houses your base layer shapefiles.

Add a states layer to your map.

Make sure that the SLOSH layer is on top of the 
state layer.  

Open the SLOSH Layer Properties and click on 
the Display tab.

Set the transparency level to 40% and click OK.

Save the symbology of the SLOSH layer. Right- 
click on the layer, and select Save As Layer 
File. Browse to the SLOSH folder on your hard 
drive, and click OK to accept the default name of 
the new .lyr file.

SLOSH Model Run



Map Production 8-14

For FEMA
GIS Support Tutorial

Add and symbolize the data: You now have symbolized SLOSH data and a state boundary displayed together.

At this point you are ready to begin making a map of your SLOSH data. Several examples follow that show what the 
NOAA Coastal Services Center has provided to members of FEMA in the past.

Refer to the “Basics of Cartography” chapter at the end of this manual for addition information.

SLOSH Model Run
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6-Hour Flash Flood Guidance

Purpose: This type of map presents a 6-hour estimate for flash flooding in given areas. National Weather Service River 
Forecast Centers (RFC) routinely issue flash flood guidance throughout the day for every county in their areas. Flash 
flood guidance estimates the average number of inches of rainfall for given durations required to produce flash flooding 
in an indicated county. These estimates are based on current soil moisture conditions. Note that in urban areas, less 
rainfall is required to produce flash flooding. The higher the flash flood guidance values, the more rainfall the soil will be 
able to absorb, and thus the less likelihood of flash flooding. The lower the values, the less rainfall the soil will be able to 
absorb, and thus the more likelihood of flash flooding. Areas that have received large amounts of antecedent rainfall will 
be more susceptible to flash flooding because the soil will not be able to absorb as much rainfall and will therefore have 
lower flash flooding guidance values. Keep in mind that flash flood watches and warnings are always issued by local 
weather forecast offices.   

Source Data: This type of map uses data that originate from the NOAA National Weather Service’s (NWS) Southern 
Region Headquarters. 

Download: Open a Web browser and visit the NWS Flash Flood Guidance Web site:  
www.srh.noaa.gov/rfcshare/ffg.php?location=SR

This tutorial will demonstrate how to download data from this Web site, bring it into ArcMap, and create a presentation 
map using other data sets.
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Download the data: Once on the Web site 
(www.srh.noaa.gov/rfcshare/ffg.php?location=SR), select the 
specific product that you want to download. In this case, select 
6 Hour Flash Flood Guidance.  

Choose which state has the flash flood guidance data you 
want. For this example, select Florida.

Begin the downloading process by clicking on the Download 
DBF File button.

This will open another window in your browser.

An important note: The flash flood guidance (FFG) 
shapefiles may be updated at 2:45, 7:45, 8:45, 9:45, and 10:45 
a.m. – and 12:45, 1:45, 3:45, 7:45, 8:45, 9:45, and 10:45 p.m.  
These times are Eastern Standard Time (EST).

The frequency and times when each River Forecast Center 
(RFC) updates its FFG values will vary quite a bit. Some RFCs 
only update once daily, while others update four times a day.  

The graphics and DBase (.dbf) files are run more frequently in 
the morning between 7:45 a.m. and 1:45 p.m. and then again 
during the evening hours around midnight to include the latest 
FFG possible from the RFCs. 
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6-Hour Flash Flood Guidance

Download the data: There are two files to download.  

The first is a .zip file that has a compressed ESRI shapefile for 
the state and its county boundaries. This shapefile is static in 
nature and does not change.  

The second is a table of data values that are stored in DBase 
format (.dbf). The values in this table change several times a 
day. Keep in mind that this file will need to be downloaded 
each time you want to make a current map of flood forecast 
guidance values.

Click on the Download Now link for the shapefile that is 
compressed in the .zip format.  
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6-Hour Flash Flood Guidance

Download the data: When prompted in the File Download 
window, click on the Save button to browse to a folder on your 
hard drive where the data will reside.

You should create an empty data folder that has a name which 
is easy to remember. Once created, click on the Save button.



Map Production 9-5

For FEMA
GIS Support Tutorial

6-Hour Flash Flood Guidance

Download the data: After several moments, the data will 
download into your new data folder.

Return to the Web browser and repeat this process for the .dbf table.  
Remember to save the file into the same folder as the .zip file. This is a 
very important thing to remember: the shapefile will only work properly if 
it is coupled with the .dbf table. If they are not in the same folder, then 
the shapefile is not complete.
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Download the data: Once the .dbf table is saved to your hard drive, open Windows Explorer to view the two files.  
Navigate to the data folder.

The individual files contained within the .zip file need to be 
uncompressed. Double-click on the .zip file to start a 
compression utility program on your PC. Examples may 
include WinZip or PKZip.  

Once the program opens and loads the .zip file, you will 
see the individual files that comprise the shapefile (minus 
the .dbf table).

Click on the Extract button to specify where the 
data should be written.
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6-Hour Flash Flood Guidance 

Download the data: In the Extract window, navigate to the data folder 
where the original downloaded files exist. You want to keep all of these 
files together. Click Extract. 

You will now see the individual files uncompressing. Click Done when this 
process is complete.

Close the .zip utility program.
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Rename the layer: Open ArcCatalog to rename the shapefile to include the date. Click on Start > Programs > 
ArcGIS > ArcCatalog.

Once the program opens, browse to the directory that 
contains the FFG layer. Right-click on the layer and select 
Rename. It will be a good idea to add the date of the data 
so the file can be distinguished from other FFG data.

Once the date has been added to the end of the file, you 
are ready to proceed to the next step.
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Add and symbolize the data: Open ArcMap to add the shapefile. Click on Start > Programs > ArcGIS > ArcMap.

Once the program opens, click on the Add Data 
button that is found at the top of ArcMap.  

This will start the dialog window that lets users browse to 
their data. Navigate to the data folder and select the 
shapefile. Click Add.

The shapefile is then added to ArcMap’s table of contents. Notice 
that this shapefile contains only a portion of counties within the 
United States, so do not be alarmed if you see similar results.
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Add and symbolize the data: You will symbolize these counties by their reported Flash Flood Guidance Value for the 
next 6 hours. Right-click on the name of the layer in the table of contents and select its Properties at the bottom of the 
context menu.

Included with the shapefile you downloaded is an 
ArcView Legend file (.avl). This will provide the proper 
symbology to assign to the counties. Select the 
Symbology tab and then click on the Import button to 
begin this process.

Once the Import Symbology window opens, select Import 
symbology definition from an ArcView 3 legend file (.avl):.  
Click on the Browse button (yellow folder).
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Add and symbolize the data: Navigate to the data folder and select the .avl file that is saved there. Click on the 
Open button.

Once the path to the proper legend file is established, 
click OK.
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Add and symbolize the data: The following window will open and prompt you for the specific Value field in the attribute 
table you want to assign symbology. Click on the drop-down menu, select HR6, and then click OK.

You will see the predefined symbology appear in the Layer Properties window.  
After you have reviewed the classes, click OK to assign the symbology.
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Add and symbolize the data: Notice that the symbology is now assigned to the layer. Zoom in to Florida to get a closer 
look at the data for that state.

At this point you are ready to begin making a map.  
Several examples have been included of what the NOAA 
Coastal Services Center has provided to members of 
FEMA in the past.

Refer to the “Basics of Cartography” chapter at the end of 
this manual for additional information.
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120-Hour QPF / 6-Hour Flash Flood Guidance Difference

Purpose: See the definitions of the 120-Hour Quantitative Precipitation Forecast (QPF) and 6-Hour Flash Flood 
Guidance (FFG) products for individual product descriptions. This comparison takes the 120-hour QPF and 6-hour FFG 
values and converts them to rasters using the same grid cell sizes and subtracts the 6-hour FFG values from the 120- 
hour QPF. The result is a raster with positive and negative values. The positive values indicate amount of rainfall 
(inches) forecasted by the 120-hour QPF that is above the 6-hour FFG.  This can be used to show the areas that will 
exceed the 6-hour FFG based on the rainfall predicted to occur over the next 120 hours. The resulting map shows (in 
inches) the amount of rain that is forecast to fall over 120 hours that will be above the 6-hour FFG values. Thus, one can 
infer that this amount will be available to become 100% runoff and that these areas are vulnerable to flash flooding. 

CAUTION: The 120-hour QPF values are the total rainfall predicted over 120 hours. There is no indication of amount in 
smaller time increments, like 6 hours. Therefore, this comparison may not be accurate because the total QPF amount 
may not fall in a 6-hour period. This should only be used as guidance to determine where flash flooding potential is likely 
to occur over a 120 -our period.

Source Data: This type of map uses data that originate from the NOAA National Weather Service’s (NWS) Southern 
Region Headquarters. 

Download: Refer to the 120-Hour QPF module for download instructions for those data.

Refer to the 6-Hour Flash Flood Guidance Value module for download instructions for those data.
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Process the data: Follow the directions to download and process the 120-Hour QPF data for a given study area. Your 
results should look like the following example. Be sure to add a state or county boundary layer to help identify the area 
of concern.

To compare the 120-hour QPF data to the 6-Hour 
Flash Flood Guidance layer you need to convert 
each to a raster with equal sized cells. Use the 
Spatial Analyst extension to perform the feature 
(shapefile) to raster conversion.  

To use Spatial Analyst, click on View > Toolbars > 
Spatial Analyst.  You will see the toolbar appear 
inside ArcMap.

You can drag and dock this toolbar to the ArcMap window 
or let it “float” around in ArcMap. You should now enable 
the extension by clicking on Tools > Extensions.
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Process the data: Once the extension window appears, check on Spatial Analyst to enable the extension.           
Click Close.

Click on the Spatial Analyst menu and select Convert > Features to Raster 
as demonstrated in the graphic below.
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Process the data: In the Features to Raster dialog, set the Input features layer as the QPF layer. To ensure the correct 
attribute data are transferred from the polygon layer to the raster, set the Field drop-down to APCP.

Set the Output cell size as 0.18. This should also be the same cell size 
used for the 6-Hour FFG layer.

Lastly, browse for a directory to write this new raster into. Remember 
that because this is a raster, there is a 13-character limitation in the file 
name. It is also a good idea to capture the cumulative date of the QPF.

Click Save when you are done.



Map Production 10-5

For FEMA
GIS Support Tutorial

120-Hour QPF / 6-Hour Flash Flood Guidance Difference

Process the data: Notice that the raster is added at the bottom of the table of contents and looks similar to the original 
polygon layer. One big difference is that the cells are now in a horizontal/vertical orientation, whereas they were oriented 
diagonally in the polygon layer. This won’t pose a problem since the spatial extent of the cells is basically the same.

View these data better by turning off the original polygon 
layer and dragging the new raster above the county 
boundary layer. Open the layer properties of the raster, 
click on the Display tab, and set the transparency to 40%.

Click OK when you are done.
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Process the data: Right-click on the 0 class and set it to No Color. This allows you to see through to the counties.

Now add the 6-Hour FFG layer to ArcMap. You may 
receive the following warning message, which 
announces that the spatial reference (or projection) of 
the raster layer differs from that of the 6-Hour FFG 
layer. However, ArcMap is able to reconcile this through 
its ability to perform projections “on the fly.”

Click OK to dismiss this window.
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Process the data: Once this polygon layer is added, it should be converted to a raster just like the 120-Hour QPF data.  
Again, using the Spatial Analyst menu, select Convert > Features to Raster.

In the Features to Raster dialog, make sure the Input 
features drop-down is set to the FFG layer. Set the Field 
from which attributes will be transferred to HR6 and 
change the Output Cell Size to match the size you 
specified for the 120-Hour QPF raster (0.18 decimal 
degrees). This must be the same in order for the two 
rasters to be compared!
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Process the data: Specify the Output Raster folder and file name by clicking on the Browse button, and navigate to the 
same directory as the original 120-Hour QPF shapefile. Type the name of the raster while remembering the 13-character 
limitation and the need to retain the date of the data. 

Click on Save when you are finished. Then click OK on 
the Features to Raster dialog window to begin the 
conversion process.
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Process the data: Turn off the 6-Hour FFG shapefile and review the converted FFG raster file.

To compare the difference between the two rasters, you 
will use the Raster Calculator within Spatial Analyst.

Click on Spatial Analyst > Raster Calculator to start 
the program.  
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Process the data: Once you open the Calculator, you may want to expand its offerings by clicking on the            button 
at the bottom of the window to reveal more advanced mathematical operators.

Build the calculation expression in the following manner:

Click the Integer or  Int button once to start the expression.  

Double-click on the QPF raster.

Click on the minus (-) operator.

Double-click on the FFG raster.

Your expression should look like this example.

Click on the Evaluate button when finished.

The calculation will take a few moments to complete. 

You may receive a warning message. This is normal and can be ignored. 
Click Yes to dismiss the window.
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Process the data: The resulting difference raster may look like the example below. Notice that there are negative 
values. You are not interested in seeing those.

Open up the Calculation raster’s Layer Properties. Click on 
the Symbology tab. Select all classes containing a 
negative value or “0” and delete them by clicking on the 
Remove button.

When the process is finished, click OK to see the changes.
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Process the data: You now want to symbolize the classes with a logical color ramp.

Open up the Calculation raster’s Layer Properties again 
and click on the Symbology tab. Select a color ramp that 
is a logical progression from red to blue.  

Since you want the highest amounts of rain to be red, you 
need to reverse the order of these colors.

Click on the Symbol field and select Flip Symbols. Click OK to see 
the new symbolization.
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Process the data: Since this layer is useful but at the moment considered “temporary,” it should now be 
saved permanently. 

Right-click on the layer and select Make Permanent…

The following dialog window will appear. Specify the new 
name of this raster, and click Save when finished.

Now the layer can be reused at any time.



Map Production 10-14

For FEMA
GIS Support Tutorial

120-Hour QPF / 6-Hour Flash Flood Guidance Difference

Process the data: Although the name does not change in 
the table of contents, you can see that the new raster has 
been added to the folder you specified.  

Additionally, you can see the new name specified inside 
the layer’s properties window within the Source tab.

It might be helpful to rename the layer in the table of contents 
to help remember how it was developed.

At this point you are ready to begin making a map. Several 
examples have been included to show what the NOAA 
Coastal Services Center has provided to members of FEMA 
in the past. Refer to the “Basics of Cartography” chapter at 
the end of this manual for additional information.
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Purpose: See the definitions of the Cumulative Rainfall Using Stage III Multi-Sensor Precipitation Estimates and 6-Hour 
Flash Flood Guidance (FFG) products for individual product descriptions. This comparison converts the Stage III Rainfall 
and 6-hour FFG values into rasters using the same grid cell sizes and subtracts the 6-hour FFG values from the Stage III 
Rainfall. The result is a raster with positive and negative values. The positive values show the amount of rainfall (inches) 
above the 6 hour FFG as indicated by the Stage III Rainfall estimation. This can be used to show the areas that will 
exceed the 6-hour FFG based on cumulative rainfall using Stage III Multi-Sensor Precipitation Estimates. The goal of 
this analysis is to show counties where flash flooding may have occurred. 

Since Stage III data describe “past” rainfall and FFG data describe “forecast” conditions, it is not possible to perform a 
meaningful comparative analysis for the present day. Instead, the user should archive the present day’s (i.e., today) FFG 
data for comparison with Stage III data available on the second day (i.e., tomorrow). For example, an analyst wishing to 
create a map as outlined in this module would need to download the 6-hour FFG data for today, archive the file, and use 
it for comparison tomorrow, once today's Stage III data are available. 

Source Data: This type of map uses data originating from NOAA’s National Weather Service’s (NWS) Southern Region 
Headquarters. 

Download: Refer to the Cumulative Rainfall Using Stage III Multi-Sensor Precipitation Estimate module for download 
instructions for those data.

Refer to the 6-Hour Flash Flood Guidance Value module for download instructions for those data.
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Process the data: Follow the directions to download and process the Stage III Rainfall data for a given study area.  
Your results should look like the following example. Be sure to add a state or county boundary layer to help identify the 
area of concern.

To compare the Stage III Rainfall data to the 6-Hour 
Flash Flood Guidance data, you need to convert each 
to a raster with equal-sized cells. You need to use the 
Spatial Analyst extension to perform the feature 
(shapefile) to raster conversion. 

To use Spatial Analyst, click on View > Toolbars > 
Spatial Analyst. You will see the toolbar appear 
inside ArcMap.

You can drag and dock this toolbar to the window or let it 
“float” around in ArcMap. You should now enable the 
extension by clicking on Tools > Extensions.
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Process the data: Once the extension window appears, check on Spatial Analyst to enable the extension.                  
Click Close.

Click on the Spatial Analyst menu and select Convert > Features to Raster 
as demonstrated in the graphic below.
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Process the data: In the Features to Raster dialog window, set the Input features layer to be the Stage III Rainfall layer.  
To ensure the correct attribute data are transferred from the polygon layer to the raster, set  the Field drop-down menu 
to GLOBVALUE.

Set the Output cell size as 0.08. This should also be the same cell size 
used for the 6-Hour FFG layer. 

Lastly, browse for a directory to write this new raster into.  
Remember that because this is a raster, there is a 13- 
character limitation in the file name. It is also a good idea to 
capture the date of the Stage III Rainfall data.

Click Save when you are done. Then click OK in the Features 
to Raster dialog to begin the conversion process.
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Process the data: Notice that the raster is added at the bottom of the table of contents and looks similar to the original 
shapefile layer. One big difference is that the rainfall values assigned to each cell of the raster is an averaging of the 
rainfall values of the original points in the shapefile (expressed in inches).

View these data better by turning off the original point layer 
and dragging the new raster above the county boundary 
layer. Open the Layer Properties of the raster, click on the 
Display tab, and set the transparency to 40%.

Click OK when you are done.
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Process the data: Now add the 6-Hour FFG layer to ArcMap. You may receive the Warning message shown below, 
which announces that the spatial reference (or projection) of the raster layer differs from that of the 6-Hour FFG layer.  
However, ArcMap is able to reconcile this through its ability to perform projections “on the fly.”

Click OK to dismiss this window.
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Process the data: The 6-Hour FFG layer is added but not symbolized as outlined in its module. Consult this module and 
follow the steps to symbolize the layer properly.

Once this polygon layer is symbolized, you will convert it to 
a raster. Again, using the Spatial Analyst menu, select 
Convert > Features to Raster.
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Process the data: In the Features to Raster dialog, make sure the Input features drop-down is set to the FFG layer.  
Set the Field from which attributes will be transferred to HR6, and change the Output Cell Size to match the size you 
specified for the Stage III Cumulative Rainfall raster (0.05 decimal degrees).  

Specify the Output Raster folder and file name by clicking on the Browse 
button, and navigate to the same directory as the original FFG shapefile. 
Type the name of the raster, while remembering the 13-character limitation 
and a need to retain the date of the data. 

Click on Save when you are finished. Then click OK on 
the Features to Raster dialog window to begin the 
conversion process.
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Process the data: Turn off the 6-Hour FFG shapefile and review the converted raster file.

To compare the difference between the two rasters, you 
will use the Raster Calculator within Spatial Analyst. Once 
you open the Calculator, you may want to expand its 
offerings by clicking on the              button at the bottom of 
the window to reveal more              advanced  
mathematical operators.

For this particular map, you will compare the difference 
between the Stage II Rainfall values and the 6-Hour FFG 
values. Begin building the raster analysis expression by 
double-clicking on the Int button. 

Double-click on the QPF raster.

Click on the minus “-” operator.

Double-click on the FFG raster.
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Process the data: Your expression should look like the example below. Make sure there are spaces on either side of 
the minus sign “-” that separates the two rasters. Click on the Evaluate button when finished.
The calculation will take a few moments to run. 

You may receive the following message.

This is normal and can be ignored. Click Yes to dismiss the 
window. Turn off the 6-Hour FFG shapefile, and review the 
converted raster file.
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Process the data: Notice the Calculation raster layer is added to the table of contents. Turn off all other layers to review 
the results.

The colors assigned to the classes of the raster are not 
meaningful. Therefore, open the raster’s Layer Properties 
window, and click on the Symbology tab.

Change the Color Scheme to the Red to Blue ramp.  
Change the order of the colors by clicking on the Symbol 
field, and select Flip Colors. Click OK.
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Process the data: The resulting difference raster may look like the example below. Notice there are negative values. 
You are not interested in seeing those.  

Open up the Calculation raster’s Layer Properties window, 
and click on the Symbology tab. Select all classes 
containing a negative value or “0” and delete them by 
clicking on the Remove button. 

To see the counties below the raster, set the transparency 
of the raster to 40% (do you remember how?)
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Process the data: Since the Calculate layer is useful but at the moment is considered “temporary,” it should now be 
saved permanently. 

Right-click on the layer and select Make Permanent…

The following dialog window will appear. Specify the new 
name of this raster and click Save when finished.

Now the layer can be reused at any time.
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Stage III Rainfall / 6-Hour Flash Flood Guidance Difference

Process the data: Although the name does not change in the table of contents, you can see that the new raster has 
been added to the folder you specified.  

Additionally, you can see the new name specified inside 
the Layer Properties window within the Source tab.

At this point you are ready to begin making a map. An example has been included that shows what the NOAA Coastal 
Services Center has provided to members of FEMA in the past.

Refer to the “Basics of Cartography” chapter at the end of this manual for additional information.

It would be useful to rename the layer in the table of 
contents to help remember how it was developed.
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Purpose: This type of map presents an estimate of the potential for inland flooding.

Source Data: National Hurricane Center (NHC) and local weather information, forecast tracks, and evacuation time 
calculations can be plotted manually, but this can be an onerous task during an emergency. A computer program called 
HURREVAC automatically tracks this information and displays the results graphically. The computer program can be 
obtained from county, local, and state emergency management offices. (Please note that this program is not 
available to the general public.)

Significant River Flood Outlook

HURREVAC updates current and forecast storm data and then 
displays the track of the storm in various formats. Using Hurricane 
Evacuation Study (HES) data, it considers the potential for storm 
surge and calculates evacuation times based on storm speed and 
intensity. HURREVAC can also be used as a "what-if" tool to help 
emergency managers determine courses of action for different 
storm characteristics.

Download: This tutorial assumes that users of HURREVAC have 
already installed the software and have some idea of how it works.
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Access the data: Begin using HURREVAC by 
going to Start > Programs > HURREVAC2000.  
Once the program opens, click on the Auto 
Download Latest button.

Once the data finishes downloading, click Exit to 
close the window.

Click on the Load Storm File button to access the 
date for a specific tropical storm.

Significant River Flood Outlook

The HURREVAC Advisory Files dialog will open. Navigate to the 
c:\Program Files\Hurrevac2000\data folder. Click on the storm name (first 
letter in name_year of storm). Click on the Load File button.
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Access the data: To view Significant River Flood Outlooks (SRFOs), click on the Rain/River menu at the top of 
HURREVAC and select LATEST National River Flood Outlook. This will display the areas expecting inland flooding for 
that day.

Significant River Flood Outlook

Bring these areas that will experience flooding into 
ArcMap for mapping. Click on the File menu and 
select Export Field(s) to GIS File…

The window below will appear.

Select the field type named NWS river flood outlook (polygons) and click 
on the Continue button.
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Access the data: A dialog window will appear that asks for the folder to save the downloaded shapefile. Specify an 
existing folder, or create a new one (e.g., c:\Significant_River_Flood_Outlook). Provide a logical name for your shapefile 
and click Save. Ideally, you should try to record the date for which the SRFO data are valid.

Significant River Flood Outlook

Open Windows Explorer and navigate to your new SRFO 
data folder. Notice that the shapefiles have been 
downloaded and saved to this location.

Open ArcMap to view these data. Select Start > Programs > ArcGIS> ArcMap.
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View the data: Add the shapefile by clicking on the Add Data button            found at the top of the ArcMap window. This 
brings up a dialog box that lets users browse to their data.

Significant River Flood Outlook

Select the SRFO layer and click Add. The layer now appears at 
the top of ArcMap’s table of contents.
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View the data: Double-click on the SRFO data layer to open the Layer Properties. Click on the Symbology tab. 

Significant River Flood Outlook

Under the Show window, click on Quantities.

Under Quantities, select Graduated Colors.

Under Fields change Value to ID.

Right-click on the Color Ramp.

Click Graphic View from the available options.  
This changes the color ramp into a textual 
description of the color ramp.

Use the Red to Green ramp to display the SRFO 
data. You may have to right-click on the symbols 
and select Flip Symbols to have value 1 equal 
green and value 3 equal red.

Once you have decided on a color ramp, click 
Apply to make the changes to the symbology.
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Significant River Flood Outlook

Select the Properties for All Symbols option.

In the Symbol Selector dialog box, under 
Options, click on the Outline Color pull-down 
menu and select No Color.

Click OK and OK again to close the Layer 
Properties box and apply the changes you have 
made to the symbology of the SRFO data layer.

This will remove the outline around each polygon 
and make the SRFO data appear more 
continuous.

View the data: Before closing the Layer Properties dialog box to return to your map, click on the Symbol header 
(indicated in the graphic).
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Click on the Add Data button and 
browse to the directory that houses your 
base layer shapefiles.

Add a counties layer to you map.

Make sure that the SRFO layer is on 
top of the counties layer.  

Open the SRFO Layer Properties and 
click on the Display tab.

Set the transparency level to 40% and 
click OK.

At this point you are ready to begin 
making a map. An example has been 
included of what the NOAA Coastal 
Services Center has provided to 
members of FEMA in the past.

Significant River Flood Outlook

View the data: You now have the SRFO data symbolized in a meaningful way. Next you will need to add some additional 
base data like state boundaries.

Refer to the “Basics of Cartography” chapter at the end of this manual for 
additional information.
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Significant River Flood Outlook
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Tropical Cyclone Wind Speed Probabilities

Purpose: This type of map depicts probabilities of sustained tropical-cyclone surface wind speeds. These probabilities 
are expressed in percent for wind speed thresholds equal to or exceeding 34, 50, and 64 knots. The probabilities are 
based on the track, intensity, and wind structure (size in terms of radii) uncertainties in the official National Hurricane 
Center forecasts.

Source Data: This type of map uses the NOAA National Weather Service’s National Digital Forecast Database 
(NDFD), found at www.nws.noaa.gov/ndfd/. The National Weather Service (NWS) provides access to gridded 
forecasts of weather elements (e.g., cloud cover, maximum temperature) through the NDFD. This database contains a 
seamless mosaic of digital forecasts from NWS field offices working with the National Centers for Environmental 
Prediction (NCEP). The database uses a 5-kilometer national grid that covers the continental U.S. and separate grids 
that cover Hawaii, Alaska, the U.S. Virgin Islands, and Puerto Rico. Each 5-kilometer grid cell has forecast 
information, allowing users to retrieve specific forecasts by entering geographic coordinates. 

The World Meteorological Organization (WMO) has adopted Edition 2 of the gridded binary data (GRIB) code as a 
standard for sharing information. GRIB, Edition 2 (GRIB2), is involved in the NDFD in two ways. First, GRIB2 is the 
code form used to transmit gridded forecasts from contributing offices to the NDFD. Second, GRIB2 is one of the 
primary forms used to transmit the NDFD grids to NWS customers and partners. 

Download: Before working with NDFD data, users must first download the GRIB2 Decoder tool that allows access to 
the data. Learn more about GRIB2 Decoder by visiting this site: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/
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Download: Register for the DEGRIB program here: www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/howto.php
At the top of the page, under step 1, click on the highlighted link to register and download the program.

Double-click on degrib-install.exe to install the program.  
A window will appear; click on the Install button and 
accept the defaults for the installer.

Tropical Cyclone Wind Speed Probabilities

Once done, download the program from here:  
www.nws.noaa.gov/mdl/NDFD_GRIB2Decoder/download.php

This page provides several different versions of the same product.  
For this tutorial, you will focus on the Microsoft Windows version.  
Click on degrib-install.exe and select Save. Specify the directory 
path for the program as c:/ndfd and copy the .exe into that folder.  
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Tropical Cyclone Wind Speed Probabilities

*Note: In most cases, the file(s) of greatest use will be the Cum. Prob. Trop. 
Cyclone Wind > 34kts or Cum. Prob. Trop. Cyclone Wind > 64kts, which 
include the cumulative probability (out to 120 hours) of an area experiencing 
tropical-storm-force or hurricane-force winds, respectively.

Download: Double-click on tkdegrib (aka NDFD GRIB2 Decoder) to start the program.

Then click on the Download tab and expand the NDFD 
data set folder if it is not already open.

Choose the region of interest and expand the folder. 
Choose the days of interest and expand the folder. 

Data for each weather element can be downloaded by 
highlighting the entire region folder, or individual weather 
elements can be downloaded by holding down the Control 
key on the keyboard and highlighting one or more 
elements.

Click on the Cum. Prob. Trop. Cyclone Wind > 64kts 
(knots)*, and then click on either the Download by FTP or 
the Download by HTTP button (either will work) at the 
bottom of the window. 

Once downloading begins, there will be an indication in the 
Message Window that it is working. Also, after the 
download button is clicked, the light blue bar near the 
bottom of the window will show the progress of the data 
download. 
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View the data: Minimize this program and open Windows Explorer. Navigate to C:\ndfd\degrib18\data\ndfd\conus 
and notice that tcwspdabv64c.bin is stored in that directory.

Tropical Cyclone Wind Speed Probabilities

This file contains important data in a binary format. Unfortunately, 
ArcGIS is unable to read this format, so the data must be 
converted into a shapefile.

Close Windows Explorer and return to the tkdegrib (aka NDFD 
GRIB2 Decoder) program.
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Tropical Cyclone Wind Speed Probabilities

Choose the time under the Valid Date field that will be 
closest to the forecasted landfall of the storm. You 
may want to have these data correspond to the same 
day and time of data in previous modules.

An easy way to name an output file inside the Output 
Filename window is to simply click on the 
Recommend button. Ideally, you should keep all of 
your regional files in the same directory.

Specify the File Type as SHP (shapefile).

Specify the type of shapefile to be Large Polygon. 

Specify Round data to: 0 decimals.

When finished, click the Generate .shp file button.  
This will create a new shapefile and copy it into the 
specified folder. Notice that it is in a different folder 
than the tcwspdabv64c.bin file.

Convert the data: Click on the GIS tab. This window lets users choose a file to convert to various GIS-friendly formats. 
Navigate to the directory of your .bin file. Double-click on tcwspdabv64c.bin to see a series of wind speed probability 
forecasts.  

When finished, click on the window that reads Done. Minimize the program and open ArcMap.
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Tropical Cyclone Wind Speed Probabilities

Add and symbolize the data: Start ArcMap by selecting Start > Programs > ArcGIS > ArcMap

Add data by clicking on the Add Data button 
found at the top of the ArcMap window. 
This will open a dialog window that lets users browse 
to their data.

Select the file and click Add. Notice the layer is now   
added to the top of the table of contents in ArcMap.

The data should now be symbolized to show the different 
forecasted wind speed probabilities.
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Tropical Cyclone Wind Speed Probabilities

Add and symbolize the data: Double-click on the layer name in the table of contents. This will open the Layer 
Properties window. Click on the Symbology tab to assign probability ranges to the polygons. 

Change the Show group on the left-hand side of the window 
to the Quantities > Graduated Colors category. Specify the 
value field as ProbWindSpdN.  Notice that a default 
classification is given.
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Add and symbolize the data: Click on the Classify button to open the Classification dialog window. Set the 
Classification Method to Defined Interval. Change the Interval Size to 10. Click OK.

Choose a color ramp that is a logical progression             
from light to dark colors or, as in the example below,       
hot to cold colors.

Since you want the highest probability for tropical cyclone 
wind speeds to be red, you need to reverse the order of 
these colors.  

Click on the Symbol field and select Flip Symbols. Click OK to see 
the new colors.

Tropical Cyclone Wind Speed Probabilities 
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Add and symbolize the data: Notice that the outline of the polygons is distracting.

To better display the data, turn the outline off by double- 
clicking on the layer to open its Layer Properties. Click on 
the Symbol header and select Properties for All 
Symbols.

Tropical Cyclone Wind Speed Probabilities 
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Add and symbolize the data: Change the Outline Color to No Color 
and click OK. Click OK in the Layer Properties window to assign        
the change.

Notice that the different wind speed probabilities are 
now easier to see.

Tropical Cyclone Wind Speed Probabilities
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Add and symbolize the data: Collapse the symbols 
for this layer by clicking on the minus sign next to the 
layer’s name.  

Add a state boundary layer for reference purposes.  
Click on the Add Data button and browse to the 
following directory:  
C:\ndfd\degrib18\data\imageGen\shapefile

Select the states.shp layer for this example and  
click Add. 

Tropical Cyclone Wind Speed Probabilities 
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Add and symbolize the data: The following Warning dialog will appear.  

This alerts the user that the data being added have a 
different spatial reference (projection system) than the 
NDFD layer currently in the table of contents.  

ArcMap’s data frame defaults to the spatial reference of 
the first layer added; however, as other layers having a 
different spatial reference are added, they will be 
automatically reprojected to the original layer.  

This is known as “projection on the fly.” This message is 
normal and can be dismissed by clicking OK.

Tropical Cyclone Wind Speed Probabilities 



Map Production 13-13

For FEMA
GIS Support Tutorial

Add and symbolize the data: Click and drag the wind speed probability layer to the top. Double-click on the layer to 
open its Layer Properties window, click on the Display tab, and set the transparency to 40% so you can see the state 
layer below it.  

Click OK to see the change take effect.

Tropical Cyclone Wind Speed Probabilities 
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Add and symbolize the data: You may also wish to exclude the value for zero probability of experiencing winds up to 
64 knots. Double-click on the layer to re-open its Layer Properties window.

Click on the Symbology tab, and then click on the Classify button to 
open the Classification dialog window. Click on the Exclusion button 
to open the Data Exclusion Properties dialog.

Create an exclusion statement. In the white space at the bottom of the 
window, type “ProbWindSpdN”=0.

Click OK three times to see the change take effect.

At this point you are ready to begin making a map. The 
following is an example.

Refer to the “Basics of Cartography” chapter at the end of this 
manual for additional information.

Tropical Cyclone Wind Speed Probabilities 
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Tropical Cyclone Wind Speed Probabilities
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Basics of Cartography

Purpose: This chapter discusses how to display the data you have processed in previous chapters through the use of 
cartography, which is defined as the art and science of making maps. Though there are many ways to represent your 
data cartographically, this chapter will discuss “conventions” you should consider for all FEMA-produced maps and look 
at specific elements that should appear for each.

All maps should include several common map elements:

• The map body (in this case, your data frame)

• A well-structured title

• A legend

• A north arrow or graticule (lines of latitude and longitude with labels)

• A scale bar

• Explanatory text (date of map, source of data, any disclaimers, etc.)

• Agency logos

• Hurricane track and category symbols

• Other FEMA- or NOAA-specific information

Each of these topics will be discussed at length in this chapter.
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Basics of Cartography

The Presidential Template: A map template is a pre-structured map that contains many (but not all) of the necessary 
map elements for a complete presentation of the data. A special template has been developed that provides a uniform 
look to all the FEMA-produced maps in this chapter. The idea of the template is to help assist users in the cartography 
process.  

Open a new ArcMap session, and when prompted, specify that 
you want to open A template file (.mxt).  Click OK.

When the dialog window opens, browse to the folder that 
contains the Presidential_template.mxt.
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Basics of Cartography 

The Presidential Template: In the Open dialog window, specify the name of the .mxt and click Open. Select the 
FEMA_Template_Landscape.mxt. The following map will appear.

Notice that several data layers and 
standard map element conventions are 
provided to give your maps the same 
appearance and structure.

Ideally, you would not need to modify 
these elements, but in cartography, that 
is seldom the case. Instead, think of the 
placement and properties of these 
elements as merely a suggested guide 
for you to follow.

You’ll notice that there is a graticule 
(lines of latitude and longitude) provided 
that demarks intersecting lines every 3 
degrees.  These will properly resize as 
you zoom in to a specific area of 
interest.

You will need to look at modifying the 
title, legend, source text, and possibly 
scale bar for each map produced.
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The Presidential Template: All the work thus far inside ArcMap has been performed within the Data View. The 
cartography component occurs within the Layout View.  When the template is open, you will see that it is automatically 
set to the Layout View.  At any time, you can change into the Layout View by clicking on the View menu and selecting 
Layout View.

You’ll notice that the layout toolbar is added to the view.  
These tools are used exclusively when working in layouts.

Each module in this chapter focuses on a specific type of 
data set. As a result, each data set will have its own type 
of map that starts with one of the FEMA templates.  
Examples for each type of map are given throughout this 
tutorial as a guide to show how your maps may look.

We are using the landscape template at this time since 
the data we will map have an east-west trend. As a result, 
the data are ideally suited for a landscape orientation. 
Data with a north-south trend should be mapped with the 
portrait template.

Basics of Cartography



Map Production 14-5

For FEMA
GIS Support Tutorial

Map Production: This example map shows a SLOSH model run. Once the template is open, click on the Add Data 
button and navigate to the folder that contains the SLOSH .lyr file you saved earlier.

Select the .lyr file and click Add. The symbolized SLOSH 
layer is now added to ArcMap’s table of contents.

Basics of Cartography
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Map Production: You will probably receive the following warning message. This is normal, because it describes how the 
coordinate system of the layer you added is different from those layers already present in the table of contents. Dismiss 
this window by clicking OK. ArcMap’s ability to perform projection “on the fly” resolves this problem.

The SLOSH data are now added to the table of contents.  
Rename the layer in the table of contents to read Feet 
above NGVD29. Zoom in to your area of interest to see the 
full extent of the data.  

You will now add a legend to the layout.

Click Insert > Legend to start the wizard.

Basics of Cartography
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Map Production: The SLOSH layer has too many classes to fit inside the legend box provided on the template. For this 
reason the legend will appear in the map body. Remove all other layers (not Feet above NGVD29) from the legend by 
selecting the name of each one in the Legend Items field. Click on the Move button to remove the layers from the 
legend. Click OK. 

In the next window, select and delete the word Legend 
and replace it with Surge. Click Next.

Basics of Cartography
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Basics of Cartography

Map Production: In the next window, change the Border to 1.0 Point and the Background color of the legend box from 
transparent (default) to White. Click Next on the remaining windows. Click Finish to create the legend.

The legend is generated and added to the layout view. If you do 
not like its appearance, you can simply hit the Delete key to 
remove it and start again.
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Map Production: Move the legend off to the side so it does not obscure the map. You may want to use the Zoom In tool 
on the layout toolbar to get a closer look at where it will be placed. You might also need to change the size of the legend 
appropriately. To do this, simply click and drag the blue squares on the corners of the legend frame.

Basics of Cartography
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Map Production: Once you are satisfied with the results, click on the Zoom Whole Page button to return to the entire 
layout.

Basics of Cartography

Change the title so it relates to the data you are displaying.  
Double-click on the existing template title to open a text box.  
For all SLOSH model run maps, the title should be 
structured in the following manner:

Storm Name
SLOSH Model Run
Basin Name
NHC Forecast Advisory Number
Date of Model Run (MMDDYY)
Hour of Model Run (HourEDT)
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Basics of Cartography

Map Production: Use the Text tool located on the draw toolbar to add the source information to the map so readers will 
know where the data originated. If the draw toolbar is not installed, simply select View > Toolbars > Draw. For all 
SLOSH model run maps, structure the source text in the following manner:

Data Source: NOAA NWS
National Hurricane Center
For Official Use Only [in red]

Place this text into the legend box. Delete the Legend text.
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Map Production: Since the source SLOSH data (and other data discussed in this tutorial) originate from a NOAA Web 
site or product, this agency’s logo should accompany all maps.  

Basics of Cartography

Add the NOAA logo to the template (Insert > Picture...)  
Ideally, it should be placed inside the credit box.

Structure the credit box text in the following manner:

Hurricane Name
FEMA Region Number 
Date (MM/DD/YY)
Time (Hour EDT)
Author Agency
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Map Production: Occasionally, it is necessary to resize the default scale bar that is provided in the template. Before 
adjusting the scale bar, ensure that the map is positioned so that all salient data are clearly visible. In this example, you 
will zoom in further to see your surge data better.  

Basics of Cartography

Notice that when you do so, the scale bar adjusts automatically. 
Feel free to move it so that it appears centered within the box.

A default north arrow is provided for visual effect.  
Technically, it is considered redundant since a graticule is 
present that conveys the same information more precisely. 

Nevertheless, you should consider leaving the north arrow 
to help orient those unfamiliar with the study area and to 
give the map additional cartographic flair.
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Map Production: Always add the past and predicted path of the storm. The following steps show how to obtain this from 
the HURREVAC program. 

1. Open Hurrevac2000 

2. Once the program is 
open, select the File 
pull-down menu and 
click on INTERNET 
DOWNLOAD of Data 
and then AUTO- 
Download Latest.  

3. After several 
moments, the text will 
stop scrolling through 
the dialog boxes.

4. Once this happens, 
click on the Exit 
button. 

Basics of Cartography
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Map Production: Go to the File pull-down menu and select Load Storm File.

Browse to Program Files\Hurrevac2000\data and select the 
letter of the storm you are interested in.

In the Load As: box, make sure Standard File is selected.

Click on the Load File button.

The track of the storm should now display inside HURREVAC.

Basics of Cartography
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Map Production: With the track of the hurricane now loaded, click on the File menu and select Export Field(s) to        
GIS File.

You may select to export a storm track to a shapefile for use in 
ArcGIS based on

• Forecast from current advisory
• Past storm track from all advisories
• Past storm track plus forecast track
• Wind ranges from current advisories

For your map, choose the third option, which shows the past 
and forecast storm track.

Click Continue>>>

Browse to a folder on your hard drive and click Save.  

In ArcMap, click on the Add Data button and browse to your 
data folder to load the shapefiles.

Basics of Cartography
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Map Production: Notice that a past and forecast storm track line appears along with the predicted locations of the storm.  

Double-click on the point layer name to change its 
symbology. The Layer Properties dialog will open. Click 
on the Symbology tab.

Basics of Cartography

Click on Quantities > Graduated Colors.  

Change the Value field you want to display to MPHWind. Set 
the number of classes to 7.
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Map Production: You need to change the range of values for your hurricane categories. Click on the Classify button.  
When the Classification dialog opens, change the Classification Method to Manual. Update the Break Values to match 
the values provided in this screen capture. These numbers represent the upper limits of various storm categories. Click 
OK when finished.

The results of the new break values will appear. Change 
the labels for each one to match the storm category as 
shown in the screen capture below.

You now need to change the symbol of each point to look like a 
standard hurricane symbol used in cartography.

Basics of Cartography
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Map Production: Click on the Symbol header and select Properties for All Symbols.

Click on the More Symbols button to select a special set of 
symbols for your hurricane layer.

Find the symbol set named Weather at the bottom of the list and 
select it. This will add additional point symbols specific to 
meteorology to your Symbol Selector.

Basics of Cartography
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Map Production: Scroll to the bottom of the symbol list and select the Hurricane symbol. Click OK.

Change the color ramp to a red to green (divergent) color 
scheme. Since the lowest wind values are assigned darker 
colors, you will need to flip the symbols around.

Basics of Cartography
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Map Production: Click on the Symbol header again, and select the Flip Symbol option. The highest winds will now 
have darker reds. Click OK to assign these changes and see the difference in the display.

Basics of Cartography

At this time, it would be wise to save these symbol settings to 
a layer file. This provides quick recall of these settings for 
future hurricane point layers.
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Map Production: Right-click on the layer name and select Save as Layer File. Browse to a folder and name your layer 
file Saffir_Simpson.lyr as shown in the screen capture below. Click Save to create the file.

Basics of Cartography

When you want to reuse this layer file, simply right-click on 
another hurricane point layer, select Properties, select the 
Symbology tab, and click on the Import button. Browse to 
the location of the Saffir_Simpson.lyr file and click OK to 
retrieve the predefined symbology.

You may want to modify the legend since the hurricane 
point and line layers have been added. If you want to leave 
them in the legend, you should rename the layers in the 
table of contents to something that makes sense.

You should also note that the Hurricane Track layer symbol has 
been changed to a thick red line to help it stand out.
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Map Production: Add surge values onto the map by placing labels at specific points of interest. To add labels, return to 
the data view (View > Data View).  

Basics of Cartography

Click on the name of the surge layer in the table of contents. 
Open its Layer Properties and select the Label tab.

Set the Label Field to be equal to the original name of the 
layer. In your case it is w32_fmy. Click OK.
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Map Production: Click on the drop-down arrow on the text tool located on the draw toolbar. A group of text tools will 
appear. Select the Label text tool (looks like a shopping tag).

Basics of Cartography

The Label Tool Options dialog will open. Select Place label at position clicked and 
close the dialog.
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Map Production: Click various locations along the coastline where you want to illustrate the amount of surge.  
Unfortunately, the text does not stand out very well with the colored background.   

Basics of Cartography

To improve visibility, select the text values and assign 
a halo background behind them.

Click on Edit > Select All Elements. You will notice 
faint dashed blue boxes around each of the values.

Right-click on one of the selected values. Select the 
Properties option. The changes you make for this one 
element will affect all elements selected.

Select the Text tab and click on the Change Symbol 
button at the bottom of the window.

In the Symbol Selector dialog window, click on the 
Properties button to open the Editor dialog window.

Select the Mask tab. Click on the Halo style, and set 
the size of halo to 1.  Click OK three times.

You should clearly see the values appear with a white 
halo background.
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Map Production: Add hurricane position values onto the map by automatically labeling each point.  

Basics of Cartography

Right-click on the hurricane point layer and open its 
Layer Properties dialog window. 

Select the Labels tab.

Change the Label Field to Date.  

Click on the Symbol button to open the Symbol 
Selector dialog window.

Click on the Properties button to open the Editor 
dialog window.

Click on the Mask tab, select Halo, and resize to 1.

Click OK three times.

Right-click on the layer again. Select Label Features.

Each point will now label with the day and time the 
storm will be present at that location with a halo 
background.
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Map Production: Add the time of the hurricane forecast track onto the map with free text.  

Basics of Cartography

Click on the the Text tool drop-down and select the 
New Text tool.  

Click anywhere inside the Data View to start a text 
string. Type supporting text for the track in the 
following manner:

NHC Forecast Track
Date (MM/DD/YY)
Time (Hour EDT)

Once it is added, move the text string to run parallel to 
the storm track.  

Use the Rotate tool found on the draw toolbar to angle 
the text appropriately.

Create a halo around the text in the same way as the 
other text elements (remember how?).

Hint: Right-click on the Text > Properties.
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Map Production: Lastly, add text to denote water bodies in the study area. A few cartographic conventions should be 
observed for water body text:

Basics of Cartography

Use uppercase text
Use italics text style
Use blue or white text color 

In this example, add text for the Gulf of Mexico and 
Atlantic Ocean. Extra credit will be given for Lake 
Okeechobee!

Once you are finished adding text, go back to the 
Layout View to see the results.

The following page is an example of what you should 
try to achieve.
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Zulu Time: The world is divided into 24 time 
zones. The "clock" at Greenwich, England, is 
used as the standard clock for international 
reference of time in communications, military, 
aviation, maritime, and other activities that 
cross time zones. The letter designator for 
this clock is Z, for Zulu.

Times written in military time (24 hour format) 
are four digits, such as 1830Z (6:30 pm), with 
the Zulu suffix. Zulu Time is officially named 
Coordinated Universal Time or UTC. This 
time zone had previously been called 
Greenwich Mean Time (GMT) but was 
replaced with UTC in 1972 as the official 
world time  standard changed. 

Table: Converting Local Time to Zulu Time
Use the table on the right to convert local time 
to Zulu time, and vice versa. Find your local 
time in the first column (in blue) and then use 
the corresponding Zulu time (in red) listed 
under your time zone.

Appendix

Sources:
Zulu Chart – http://hurricanes.noaa.gov/zulu-utc.html

Explanatory Text – Mobile Aeronautics Education 
Laboratory, accessed on 19 November 2005,
www.lerc.nasa.gov/WWW/MAEL/ag/zulu.htm
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